summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/pyzmq
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest4
-rw-r--r--dev-python/pyzmq/pyzmq-20.0.0.ebuild13
-rw-r--r--dev-python/pyzmq/pyzmq-22.1.0.ebuild73
3 files changed, 83 insertions, 7 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index b542e938363d..28a22cc29d28 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,3 +1,5 @@
DIST pyzmq-20.0.0.gh.tar.gz 393041 BLAKE2B 1f22f556f5d0f2755c2e56411fdb9f583bbdfad6315e4e72fbaa1fb18d0ad5436ee0ee8d17497641421cea3f4e1b53b8ff85bf7ced96c8f1c80db0be901ca3d5 SHA512 30359e501e76d6ec14175622d6c970d9ec0f227b372d2b1c6e6650be812dd47017b797a016f5a2da83f72d00536e64d2f005a38003c9a1b4fbb7266f2640782d
-EBUILD pyzmq-20.0.0.ebuild 2673 BLAKE2B 50c577da5d69834d1cd3f6ab350e198c94fd42f348827b1267b6087064204fe7f416690b6805c8a1145c786941d2fb1f2510af8fe4b4954eac7c6cb39bdc301e SHA512 010d9e997d59887f85911753b0dde3d5932c6872c6a7e06595a8e81f3e576fd73e2577ecde4206bf8372b0d6671c80b50b5adda98f42d9b69c51c7da83ab9344
+DIST pyzmq-22.1.0.gh.tar.gz 401919 BLAKE2B ec43c62e68633a7e0ac06e7a717b6409e444dbd1347154c2a29a2dfb00916829656308122fa2cf0fc1e3013c82ba6bcc5e11b86582f95d46f43e9e81f6d8ff74 SHA512 aa135279927bff07339b99b4ebbc7d47effbfba7df99d3576088fe0e7d4a3ad44174a928e8b94afdeaf531c6a30cbb7bb88bce7fe19e7e5420b079ffb8e8690e
+EBUILD pyzmq-20.0.0.ebuild 2653 BLAKE2B c0d0fc48eb69fc23c199f66d8171c7b3eb57d752f3b00e8f667eb41a0cce14b967b2d09a4ee98d3d3713532931d7ee154bdf0d1e67b218d24475cdb5dc761b2a SHA512 6841126e1f898b56f784606725d916ecbba38f0a99154a179cdcffb905f574072c66cea39c7f5368c064d2208a571bf63cafac4ea9b5a8af998c4d6e591ac50a
+EBUILD pyzmq-22.1.0.ebuild 1715 BLAKE2B 2eab05d7d3fde32259ec3f7892c86617b52ee5c3533631c166480b80fe31959ae803af9fbb9e750cde719d103abba2894ce37330b0ffac8f47872033e8bb7f3e SHA512 1880600c17a9af2ff9279490c69faa13bbc0d36e611c15f338e303d54d56bf125369bb94035b0d9cb0d60fdd140f530ba8f77be05b736b1db69d8bb2e45a111b
MISC metadata.xml 428 BLAKE2B 36d5533b4bcb9fe9aa69847e05599da6400c634c73f1f00321e0a4492b053fbc9e1fcf0f9a22782162b8bbafadb9a343b19da35e732e7898fb3784473564438a SHA512 af1c8716dbd0846be80b90587ffec0c51e0f56f277a659cce15f1114cc0d3889ebe9fd92fdbcdc62b04a9919f48037b44153f7cb5e66d4719ef649aec933ca12
diff --git a/dev-python/pyzmq/pyzmq-20.0.0.ebuild b/dev-python/pyzmq/pyzmq-20.0.0.ebuild
index 27c307eec8e9..1e654efef840 100644
--- a/dev-python/pyzmq/pyzmq-20.0.0.ebuild
+++ b/dev-python/pyzmq/pyzmq-20.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -76,12 +76,13 @@ python_test() {
zmq/tests/test_security.py::TestSecurity::test_plain
zmq/tests/test_socket.py::TestSocket::test_large_send
zmq/tests/test_socket.py::TestSocket::test_tracker
- zmq/tests/test_socket.py::TestSocketGreen::test_large_send
- # hanging tests
- zmq/tests/test_socket.py::TestSocketGreen::test_tracker
+ # green-thing tests cause hangs or crashes
+ zmq/tests/test_socket.py::TestSocketGreen
+
+ # hangs
+ zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
)
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests failed with ${EPYTHON}"
+ epytest ${deselect[@]/#/--deselect }
}
diff --git a/dev-python/pyzmq/pyzmq-22.1.0.ebuild b/dev-python/pyzmq/pyzmq-22.1.0.ebuild
new file mode 100644
index 000000000000..c1619471f402
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-22.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit flag-o-matic distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+draft"
+
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts]
+"
+# it uses cffi backend for pypy, cython backend for cpython
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ "dev-python/numpydoc"
+
+python_configure_all() {
+ tc-export CC
+ append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
+}
+
+python_compile() {
+ esetup.py cython --force
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local deselect=(
+ # TODO
+ zmq/tests/test_constants.py::TestConstants::test_draft
+ zmq/tests/test_cython.py::test_cython
+
+ # hangs often
+ zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
+ )
+
+ cd "${BUILD_DIR}"/lib || die
+ epytest -p no:flaky ${deselect[@]/#/--deselect } \
+ --ignore zmq/tests/test_mypy.py
+ rm -rf .hypothesis .pytest_cache || die
+}