summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
commit7c68db06bb531670c1261374c0133d652b476bd7 (patch)
tree5bbbde86ec021664b3c6dfaf90e1175f8378949c /dev-python/pyzmq
parent0987983e8588d2819bb2ceb029792d511cee0bda (diff)
gentoo auto-resync : 12:08:2022 - 14:22:05
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest2
-rw-r--r--dev-python/pyzmq/pyzmq-23.2.1.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index e6999ca11a76..4bbf316a6cfd 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,5 +1,7 @@
AUX pyzmq-23.2.0-libdir.patch 510 BLAKE2B cb7884416d3e15f735412d69a7ae0decbbf8eca14ae909b23e68231a65b3ad36d021b5c6f5315a3cb982cd571913ce021cc5df60509d90b28d4353dd7bd316e8 SHA512 f268d03de45971d50a89210366b4aef0e79e652a45d650fc3e4a6711558ee186ee558a2808b7c9f5c5a64ce8b9282adf024ab21a782ba614900a4813e8b6d6ca
DIST pyzmq-23.2.0.gh.tar.gz 402085 BLAKE2B 4ab26af04c76205d0770163e248e28a22aa8f710a66c9dc96e18c772338c434ad06227d57edd5aa3476fad68fa7320e9216a102b2cb19649393f1e9ef5d9599c SHA512 348482f4b6fd4ebeae8e4720a7005ed35eccee2bf26b0128115b756ee560156b34e6f043c96b71a84d47b1313bd2d8e0ed0f74c7768e23cbf65bd906036800c5
+DIST pyzmq-23.2.1.gh.tar.gz 402170 BLAKE2B 4cedd065cecbabc0e18928423e853a38953cd1f360fc326573c60bf69ffefadf3bed556d9d71eedf824e646ae23640d14b6aa8938c397c367be32cc36d300e38 SHA512 4ba236b87db062b245a04530de5b1e8385491107ae8de465f6f664c75ab8a929d57491eb3f8dddf31ff1db7b1eee89a6892a9a844bc285096cc9960704b36c9c
EBUILD pyzmq-23.2.0-r1.ebuild 1944 BLAKE2B ddb71887234f1d8fc509f8b100aa33a80e929ccdafb3e4c7513886dde4f04dfafe1ab6be0891cd8c3408e9a1dd53f3cda23f0ede3a2f077f5e7c0f655b1dc7cc SHA512 bc9c1f1366d4744cd953cb50de3184f8e8b2e8a45137870d39e297e1fbb8defc2c12d03ff746568b8ef17d247997246556b8a05b509157ac1cd5c7f9bcac2344
EBUILD pyzmq-23.2.0.ebuild 1882 BLAKE2B 64244a051abb1d374d87d202887385482730156a21141bcbf0075358d378345e46e0c93acdb4e62866f0c529a4309a32a8671fd95d6e20f075f6d3bb17c9ac3f SHA512 03625c285825f06e5fc2fb80f442eb8ef1ff8cbaaadf1a231eda52f7c0fcff540147c056cfa2fecbdd9f995b0ff48a0c6f808c607539d49200e7a907824ff42c
+EBUILD pyzmq-23.2.1.ebuild 1944 BLAKE2B ddb71887234f1d8fc509f8b100aa33a80e929ccdafb3e4c7513886dde4f04dfafe1ab6be0891cd8c3408e9a1dd53f3cda23f0ede3a2f077f5e7c0f655b1dc7cc SHA512 bc9c1f1366d4744cd953cb50de3184f8e8b2e8a45137870d39e297e1fbb8defc2c12d03ff746568b8ef17d247997246556b8a05b509157ac1cd5c7f9bcac2344
MISC metadata.xml 548 BLAKE2B 0120b82c6a48537f80d08237f4184ff855c109a0a461adfe7921e25468928ea053cc7727c7b00ff96ea556d719e453ee27cf534b285f24f62f7d1ca4ab326770 SHA512 124145f71518d39daa57522eadc27ab4782c3fc1794543396a6b6c91dda29175c4c097d6be90d7d405823621ce66f62e169b97e086c983d7f08178e6d85cee40
diff --git a/dev-python/pyzmq/pyzmq-23.2.1.ebuild b/dev-python/pyzmq/pyzmq-23.2.1.ebuild
new file mode 100644
index 000000000000..d68843bf062b
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-23.2.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+# TODO: Find out exactly where this error comes from
+# error: '<' not supported between instances of 'str' and 'int'
+#DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="threads(+)"
+
+inherit flag-o-matic distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+draft"
+
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts]
+"
+# it uses cffi backend for pypy, cython backend for cpython
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.2.0-libdir.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ "dev-python/numpydoc"
+
+python_configure_all() {
+ tc-export CC
+ append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
+}
+
+python_compile() {
+ esetup.py cython --force
+ ZMQ_PREFIX="${EPREFIX}/usr" distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ zmq/tests/test_constants.py::TestConstants::test_draft
+ zmq/tests/test_cython.py::test_cython
+
+ # hangs often
+ zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
+ )
+ local EPYTEST_IGNORE=(
+ zmq/tests/test_mypy.py
+ )
+
+ cd "${BUILD_DIR}/lib" || die
+ epytest -p no:flaky
+}