summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 17:02:59 +0000
commit6bf575618cf9022e99cbfcc64036fd9db79a749c (patch)
treef692d02fb905cd3d5bab465b790da48fb2de546b /dev-python/pyzmq
parent5944ce177026c93b7dab690db9d970567ddbf75f (diff)
gentoo auto-resync : 05:12:2023 - 17:02:58
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest2
-rw-r--r--dev-python/pyzmq/pyzmq-25.1.2.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 2b0931b12080..b91a82df255a 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,4 +1,6 @@
AUX pyzmq-23.2.0-libdir.patch 510 BLAKE2B cb7884416d3e15f735412d69a7ae0decbbf8eca14ae909b23e68231a65b3ad36d021b5c6f5315a3cb982cd571913ce021cc5df60509d90b28d4353dd7bd316e8 SHA512 f268d03de45971d50a89210366b4aef0e79e652a45d650fc3e4a6711558ee186ee558a2808b7c9f5c5a64ce8b9282adf024ab21a782ba614900a4813e8b6d6ca
DIST pyzmq-25.1.1.gh.tar.gz 389825 BLAKE2B d8e231a0eeaa6a7ad372da912cb42e96e4d862e163859b97d1c369a7940e019c074fc717685f53da06de69cfee79430e343fcd1987d768f3cc99ec75cad0955b SHA512 4aa0d5d5c1036e6ac35898c48d9612f677ee6e9345fafd02091ba81a5081f1ac8bf552eb5c03636ad643cc87e17f037013ec981d9b852c0252d30de8ce046d5a
+DIST pyzmq-25.1.2.gh.tar.gz 391272 BLAKE2B 80814704e7ea08d407859c1d71338f6ea283efcd1f3994155334aa5b60c4b6cd89167de8c78d19f8efdbeb5f4071f7b5954ea911eb6e7fbb48a0087b86579cab SHA512 b146a6dbce7cbbe2eb1da7ebd64e463067354f1566cdb4ff634b59bbb6d65e16263b6acb2d101a4ea53f870be5c753c9a12f9cc37bc5a81236681ea4fda6c56b
EBUILD pyzmq-25.1.1.ebuild 2307 BLAKE2B 518a210ee7f2b29debae65a154c954e299e433a490808aac7169b5955341db1b371949f3a18c256ac9aff30669eafd42c027140a3219e9b15b7b01dccd56b1b2 SHA512 e97f310487ff3b94e1476b9af92437f639e20751b93ad54dc6955c4bf58d2f9d1c02fa36603bdd470d4da1f78712d31c998c909d1c36da73d4a97236b2a1c379
+EBUILD pyzmq-25.1.2.ebuild 2315 BLAKE2B 7444306ad2b6e5b2abae5823456d6888514427372f8a2991e0cbb6f565a72d908be52edaf1d84d7e8f5106900f9fe58979926a7fea7599961fd800075402b31b SHA512 aad1fdd14ea11f82b63439780bf16e25e71f9e4ab203b8849df3a1a4c273b7244cfa83ee74573d884be88cddf4acf74007330f54e9c3a95d27e11d46dd6e807f
MISC metadata.xml 549 BLAKE2B 46a9a1476f68f05c71bb4f849a9e0822c58142ac036da635454f57781dcea81687accfbf9563273d4f8672a8479b098c9f03cec64e5e7f456e50ad8c7ffba9d3 SHA512 3765c31f1b0048a60d5ccf90aa1fa5416c92addb7b01c62e529419e53a4e29746d0e4434d4d4fbd5918413e7521144c8758cdef9eacf5298108c2287783908c1
diff --git a/dev-python/pyzmq/pyzmq-25.1.2.ebuild b/dev-python/pyzmq/pyzmq-25.1.2.ebuild
new file mode 100644
index 000000000000..e647f9a638db
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-25.1.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/
+"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="drafts"
+
+# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts=]
+"
+# It uses cffi backend for pypy, cython backend for cpython
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.2.0-libdir.patch
+)
+
+distutils_enable_tests pytest
+# TODO: Package enum_tools
+# distutils_enable_sphinx docs/source \
+# dev-python/numpydoc \
+# dev-python/sphinx-rtd-theme \
+# dev-python/myst-parser
+
+python_prepare_all() {
+ export ZMQ_DRAFT_API=$(usex drafts '1' '0')
+ export ZMQ_PREFIX="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ zmq/tests/test_auth.py
+ zmq/tests/test_cython.py
+ zmq/tests/test_zmqstream.py
+
+ # swap thrashing on low-mem hosts, per Debian:
+ # https://salsa.debian.org/python-team/packages/pyzmq/-/blob/master/debian/patches/skip_large_send
+ zmq/tests/test_socket.py::TestSocket::test_large_send
+ )
+ local EPYTEST_IGNORE=(
+ # Avoid dependency on mypy
+ zmq/tests/test_mypy.py
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # not implemented in cffi variant?
+ zmq/tests/test_draft.py::TestDraftSockets
+ )
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest -p asyncio -p rerunfailures
+}