summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 12:58:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 12:58:33 +0000
commit0374a8491c853f9331b95ed2a38e688e4d2edce5 (patch)
tree563dd0e0f6ee34895358db0f88d683934ca21756 /dev-python/pyzmq
parent070c77515d1406e762e9e344856546f0a15765b6 (diff)
gentoo auto-resync : 18:11:2022 - 12:58:32
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest4
-rw-r--r--dev-python/pyzmq/pyzmq-23.2.1.ebuild81
-rw-r--r--dev-python/pyzmq/pyzmq-24.0.1.ebuild2
3 files changed, 2 insertions, 85 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index e6c3b0181788..3b40fe98c847 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,6 +1,4 @@
AUX pyzmq-23.2.0-libdir.patch 510 BLAKE2B cb7884416d3e15f735412d69a7ae0decbbf8eca14ae909b23e68231a65b3ad36d021b5c6f5315a3cb982cd571913ce021cc5df60509d90b28d4353dd7bd316e8 SHA512 f268d03de45971d50a89210366b4aef0e79e652a45d650fc3e4a6711558ee186ee558a2808b7c9f5c5a64ce8b9282adf024ab21a782ba614900a4813e8b6d6ca
-DIST pyzmq-23.2.1.gh.tar.gz 402170 BLAKE2B 4cedd065cecbabc0e18928423e853a38953cd1f360fc326573c60bf69ffefadf3bed556d9d71eedf824e646ae23640d14b6aa8938c397c367be32cc36d300e38 SHA512 4ba236b87db062b245a04530de5b1e8385491107ae8de465f6f664c75ab8a929d57491eb3f8dddf31ff1db7b1eee89a6892a9a844bc285096cc9960704b36c9c
DIST pyzmq-24.0.1.gh.tar.gz 404000 BLAKE2B 01928ba3c64a5afce8e7a97821658da2067a5f6c36c0173ab2f818e83a729939f346ef67bb9a39251abf365f5772abdf7e9e62afb4cc434b5603f474485a7427 SHA512 d4b6346e780f356941a624321f1619771fb2f0ef9f65a3c0a03e837ef081ece7ed59c03f57e8647ab1cd38cfc7404d597dd294768f9e9b890115b9eebc085484
-EBUILD pyzmq-23.2.1.ebuild 1935 BLAKE2B 855ac5336b9944d944924bfaaca47880004a19e0a47e540601709716b8e3499a36c70e72846cf86830d44c0155793641d9c3f598269b7b09a87663e9e2ac37ab SHA512 69105432699471bf11dfd0c47459ec56c0cf797b10da5b147d4d428f9d14b6a8424c3252fb824e2f30cccab98744434e8e42f676bf5175471a28809a1c13e620
-EBUILD pyzmq-24.0.1.ebuild 1942 BLAKE2B 4341699c88467650b6f0dded26f02b6ab83f9f7b54eb6bf7edc4b796105ca4115a491968fb49cd675ebf6ab40d32bac8162c5512ec8d840553a04403b8c7f56c SHA512 5852f87720ef0f6ec512ac7930cc4cb95ed6e2784fb7e76690c2b8eafa58c549808a2af2b9ee1e227217848b59708a0feed6eabc0513277b73c276e49c350cd2
+EBUILD pyzmq-24.0.1.ebuild 1941 BLAKE2B fde1aab7cd553914e3f24bc1c495526437efdb9a4ea4d120c0ae7f0668a74c9581c08e66c94ef18c072202f14f6d3ad345d6f1ed4c4110bbca8f0251de745190 SHA512 ae45891df1d276025df81606e39fd8d5e0bd1e865ee41878fb3930127980949d2ee1ed4c91c95eea553fc9b5888c617cc8caf75312d483bc46094ef6de82797d
MISC metadata.xml 548 BLAKE2B 0120b82c6a48537f80d08237f4184ff855c109a0a461adfe7921e25468928ea053cc7727c7b00ff96ea556d719e453ee27cf534b285f24f62f7d1ca4ab326770 SHA512 124145f71518d39daa57522eadc27ab4782c3fc1794543396a6b6c91dda29175c4c097d6be90d7d405823621ce66f62e169b97e086c983d7f08178e6d85cee40
diff --git a/dev-python/pyzmq/pyzmq-23.2.1.ebuild b/dev-python/pyzmq/pyzmq-23.2.1.ebuild
deleted file mode 100644
index 07cca1f5054e..000000000000
--- a/dev-python/pyzmq/pyzmq-23.2.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-# TODO: Find out exactly where this error comes from
-# error: '<' not supported between instances of 'str' and 'int'
-#DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="threads(+)"
-
-inherit flag-o-matic distutils-r1 toolchain-funcs
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="
- https://zeromq.org/languages/python/
- https://pypi.org/project/pyzmq/
- https://github.com/zeromq/pyzmq/"
-SRC_URI="
- https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+draft"
-
-DEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts]
-"
-# it uses cffi backend for pypy, cython backend for cpython
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep '
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
- ' pypy3)
-"
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
- test? (
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-23.2.0-libdir.patch
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- "dev-python/numpydoc"
-
-python_configure_all() {
- tc-export CC
- append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
-}
-
-python_compile() {
- esetup.py cython --force
- ZMQ_PREFIX="${EPREFIX}/usr" distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- zmq/tests/test_constants.py::TestConstants::test_draft
- zmq/tests/test_cython.py::test_cython
-
- # hangs often
- zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
- )
- local EPYTEST_IGNORE=(
- zmq/tests/test_mypy.py
- )
-
- cd "${BUILD_DIR}/lib" || die
- epytest -p no:flaky
-}
diff --git a/dev-python/pyzmq/pyzmq-24.0.1.ebuild b/dev-python/pyzmq/pyzmq-24.0.1.ebuild
index 676c86ae003b..890945426f1c 100644
--- a/dev-python/pyzmq/pyzmq-24.0.1.ebuild
+++ b/dev-python/pyzmq/pyzmq-24.0.1.ebuild
@@ -22,7 +22,7 @@ SRC_URI="
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+draft"
DEPEND="