summaryrefslogtreecommitdiff
path: root/dev-python/pyzbar/pyzbar-0.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pyzbar/pyzbar-0.1.7.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pyzbar/pyzbar-0.1.7.ebuild')
-rw-r--r--dev-python/pyzbar/pyzbar-0.1.7.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pyzbar/pyzbar-0.1.7.ebuild b/dev-python/pyzbar/pyzbar-0.1.7.ebuild
deleted file mode 100644
index addc5815c2fc..000000000000
--- a/dev-python/pyzbar/pyzbar-0.1.7.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Read one-dimensional barcodes and QR codes from Python"
-HOMEPAGE="https://github.com/NaturalHistoryMuseum/pyzbar/"
-SRC_URI="https://github.com/NaturalHistoryMuseum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pillow[${PYTHON_USEDEP}]
- media-gfx/zbar
- virtual/python-enum34[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- virtual/python-unittest-mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "Testing failed with ${EPYTHON}"
-}