summaryrefslogtreecommitdiff
path: root/dev-python/pyyaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pyyaml
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/Manifest3
-rw-r--r--dev-python/pyyaml/metadata.xml11
-rw-r--r--dev-python/pyyaml/pyyaml-3.12.ebuild41
3 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pyyaml/Manifest b/dev-python/pyyaml/Manifest
deleted file mode 100644
index ce2c30b175f0..000000000000
--- a/dev-python/pyyaml/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST PyYAML-3.12.tar.gz 253011 BLAKE2B 530f2910acb757af9e2a738d93ace45daee3fc5764f19fbc758508e873f05ebfa2486c4f82800540e5e405e7f114f06f963e5011908fd15014ca8b8afb3a76aa SHA512 e16d8b7f4f026b6a95b11fb59c54ec5f114f6f516294eaa95e718abdf5d37c17a9c4b5e0a0a61fca04e801792d9b7fb801087cf849ff22b9581f6af204b1883a
-EBUILD pyyaml-3.12.ebuild 1073 BLAKE2B 8a1992c113a9a66e28e4e97f30592be2a497bb6f4bae4c1e117b8cd8ced8cfaaf8d1c310bd54f532ee4bd73631d541eac1bc3acb43a9dd648b2a906df06f40ca SHA512 410a29da66428ef4877bb9f6fec1f7a9ae48b079a87f26a2aa70d669eeab2c1dd1ba2a066414e89728dd457c355c8e27beffcd553e2f2108a31493c67b52a986
-MISC metadata.xml 345 BLAKE2B 8c26b8b05b08ed9abab5ed2cb36552dc9af33ee2b30cf3ebe551576d7ad44908b3dff195cd7f1a3f5af9323d17eadee407e42bfeb99150be2a0ac4b48653c1eb SHA512 1fdee5219c989b3edf11bdb63264c6ca6bd54fb1f44907bf20ce7ee6b1968c9c6f2c94363698be87d92eb6cd07a034acca7dbcffaeac40d2add8d57a240772da
diff --git a/dev-python/pyyaml/metadata.xml b/dev-python/pyyaml/metadata.xml
deleted file mode 100644
index 98375f20aa10..000000000000
--- a/dev-python/pyyaml/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <use>
- <flag name="libyaml">enable support for C implementation using libyaml</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-python/pyyaml/pyyaml-3.12.ebuild b/dev-python/pyyaml/pyyaml-3.12.ebuild
deleted file mode 100644
index f6809c7b156b..000000000000
--- a/dev-python/pyyaml/pyyaml-3.12.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_P="PyYAML-${PV}"
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="https://pyyaml.org/wiki/PyYAML https://pypi.org/project/PyYAML/"
-SRC_URI="https://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="examples libyaml"
-
-RDEPEND="libyaml? ( dev-libs/libyaml )"
-DEPEND="${RDEPEND}
- libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_configure_all() {
- mydistutilsargs=( $(use_with libyaml) )
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}
- fi
-}