summaryrefslogtreecommitdiff
path: root/dev-python/pyxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyxml')
-rw-r--r--dev-python/pyxml/Manifest4
-rw-r--r--dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch28
-rw-r--r--dev-python/pyxml/metadata.xml11
-rw-r--r--dev-python/pyxml/pyxml-0.8.4-r3.ebuild74
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-python/pyxml/Manifest b/dev-python/pyxml/Manifest
new file mode 100644
index 000000000000..f79d063cb282
--- /dev/null
+++ b/dev-python/pyxml/Manifest
@@ -0,0 +1,4 @@
+AUX pyxml-0.8.4-python-2.6.patch 1749 BLAKE2B a74d43f7494078c9a6c784f96a696d3d2880195ff4dbe1b36cd4e200e6086cb545367c123ee66af9a38c4f5ad7ac4081885307da2912d7d636ffec42da6bfe85 SHA512 3c79b8d58da01bbfb1ac3d20106e9ed40b1e3c8d52abf216c764efc505a08ce37d1d06d282e7ba311f00f0839c4314d2664efa57228e6007ebf26ca5029f5a9d
+DIST PyXML-0.8.4.tar.gz 734954 BLAKE2B e052bfd298f7e2016d7077330401d077788e22721b55d7b996f53abdc48b1717472a9d47d5567f7c0d6d53c2ca4933a77743e8248e56128f58b089eac64d0811 SHA512 68d9802a58b8ce90d668d2ba659136dc5377e224fdb837284fdcaf640f28b3bb400bf485d602689905d56121b9ffaa7f7758b4a2f262d1321c8b9890952c8a1e
+EBUILD pyxml-0.8.4-r3.ebuild 1768 BLAKE2B 8af8a228f8988dbdd43ed0fb167ce3b3359689a70838a45b1635f80fa6de9cdc99f35a8015327934c4cf9be2ff5e70667ed451cc306fa2a0473f3973d2d5ba65 SHA512 55dc8fe3984b8611930fe72f61f4275f33dda8b69c025e8ceefe33827d08cdabbceddb37ae67e547d149434fecabe3b324370d15fbf504b384814368297eb6af
+MISC metadata.xml 315 BLAKE2B bcd15fdd61eea8393ce618b9ba65073b87e56c98610539581edab6ef073de7857b3c7fbe57fd14f04de0cc2eea116e0edfa14ba801b9744ab2721e88c50804cf SHA512 36dc9d30db0cf2d1a46dfcf5869fa8f77e762291893b1e51ced88d22d599d06575de9a6a1658a8a3194daa174bcd0f69bbb59c7f671ad448eee0e28b0b56a016
diff --git a/dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch b/dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch
new file mode 100644
index 000000000000..d29b0b6a9eb2
--- /dev/null
+++ b/dev-python/pyxml/files/pyxml-0.8.4-python-2.6.patch
@@ -0,0 +1,28 @@
+diff -rupN PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py PyXML-0.8.4/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py
+--- PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2008-12-15 16:54:36.000000000 +0900
++++ PyXML-0.8.4/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2008-12-15 16:57:02.000000000 +0900
+@@ -24,8 +24,8 @@ class ParsedAbbreviatedAbsoluteLocationP
+ self._rel = rel
+ nt = ParsedNodeTest.ParsedNodeTest('node', '')
+ ppl = ParsedPredicateList.ParsedPredicateList([])
+- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
+- self._step = ParsedStep.ParsedStep(as, nt, ppl)
++ as_ = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
++ self._step = ParsedStep.ParsedStep(as_, nt, ppl)
+ return
+
+ def evaluate(self, context):
+diff -rupN PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py PyXML-0.8.4/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py
+--- PyXML-0.8.4-old/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2008-12-15 16:54:36.000000000 +0900
++++ PyXML-0.8.4/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2008-12-15 16:58:58.000000000 +0900
+@@ -28,8 +28,8 @@ class ParsedAbbreviatedRelativeLocationP
+ self._right = right
+ nt = ParsedNodeTest.ParsedNodeTest('node','')
+ ppl = ParsedPredicateList.ParsedPredicateList([])
+- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
+- self._middle = ParsedStep.ParsedStep(as, nt, ppl)
++ as_ = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
++ self._middle = ParsedStep.ParsedStep(as_, nt, ppl)
+
+ def evaluate(self, context):
+ res = []
diff --git a/dev-python/pyxml/metadata.xml b/dev-python/pyxml/metadata.xml
new file mode 100644
index 000000000000..3fd7e1e6f1fe
--- /dev/null
+++ b/dev-python/pyxml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pyxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyxml/pyxml-0.8.4-r3.ebuild b/dev-python/pyxml/pyxml-0.8.4-r3.ebuild
new file mode 100644
index 000000000000..a21d3cca4dce
--- /dev/null
+++ b/dev-python/pyxml/pyxml-0.8.4-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+MY_P=${P/pyxml/PyXML}
+
+DESCRIPTION="A collection of libraries to process XML with Python"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD CNRI MIT PSF-2 public-domain"
+# Other licenses:
+# BeOpen Python Open Source License Agreement Version 1
+# Zope Public License (ZPL) Version 1.0
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=">=dev-libs/expat-1.95.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-python-2.6.patch"
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # use the already-installed shared copy of libexpat
+ distutils-r1_python_compile --with-libexpat="${EPREFIX}/usr"
+}
+
+python_test() {
+ # Delete internal copy of old version of unittest module.
+ local BROKENTESTS=(
+ test_filter
+ test_howto
+ test_minidom
+ test_xmlbuilder
+ unittest
+ test_expatreader
+ )
+
+ for test_file in ${BROKENTESTS[@]}; do
+ test_file="test/${test_file}.py"
+ einfo "Removing dubious test \"${test_file}\""
+ rm ${test_file} || die "can't remove ${test_file}"
+ eend $?
+ done
+
+ cd test || die
+ "${PYTHON}" regrtest.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( ANNOUNCE CREDITS doc/*.txt )
+
+ distutils-r1_python_install_all
+
+ doman doc/man/*
+ if use doc; then
+ dohtml -A api,web -r doc/*
+ dodoc doc/*.tex
+ fi
+ use examples && dodoc -r demo
+}