summaryrefslogtreecommitdiff
path: root/dev-python/pyxattr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-python/pyxattr
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/Manifest1
-rw-r--r--dev-python/pyxattr/pyxattr-0.6.1-r1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index ba19f7bcbd89..30ed23ca4ad0 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -2,5 +2,6 @@ AUX pyxattr-0.6.0-xattr_header.patch 1780 BLAKE2B 43244b281bec7166d539155c66e604
DIST pyxattr-0.6.0.tar.gz 31057 BLAKE2B cf6e99c499dbcc74305970413803e5cf59508e7ee1bf247afe42e576c2dfaf118a374ad6f8721b9d9c482f8be0c222d26b82997dc1ccc79248d5f52b2064ed8d SHA512 c56bf57729b5f8c8e3e19e29fd903b7365c6644abe3dcebf57ffc2f97a1e92d0e22cdc0a967c5abee3a74ba61a2a379e31a1734f45449095bdb7895b8357a9bb
DIST pyxattr-0.6.1.tar.gz 32105 BLAKE2B 0334d056ea652492fcc7958e0caf0ec438253e287c3f2ee663c0eb059fad5f01bba02963fc90035f84c129e19ee08e11bbc5573cebef6fd7ffe5c65adddc02ab SHA512 2c2defee81e2bd7e7e7f67d33676858f27494f12ba5c3d34bd548912a058cae562e9e9ed0dc5697892d1d55c29f2a5e10455260092b63faa54e40b841c42681d
EBUILD pyxattr-0.6.0-r1.ebuild 1955 BLAKE2B 9667994511193b8a8eeeaf57cfe37b18e6a312a5815a1b14774c4b379dc934b6eee7bc18c38d635b5c5f1b538dc4dfaa7f0b68eb891adb6947154f381427b0d3 SHA512 b32596b71412070328f49bbd12a4f0b4da8c6e2e43da60613d9d7a06137260bd45b038ed304751a218a22badf7bc50deaeac5cd607fdf8a8e83ec5f8b78f3f74
+EBUILD pyxattr-0.6.1-r1.ebuild 1940 BLAKE2B 766cff999a97236397a4d273ceebd152864af9c5124102d6774171bd50c698fc0046032924bfae94cb6ba52bac354959b837036c2e0d7f083ad1d95caf269c58 SHA512 5a8f7dadf933e39f6bd232e9c9c05258e0d52a6cc4923c20519d54c9e42f2e02508893f4d9284578c26ad2427c2cf442ff0a6caceb0fac73bb60f3040e97f34c
EBUILD pyxattr-0.6.1.ebuild 1909 BLAKE2B 81f6f6654af345b2269daa2310f39a01bb7791fe49610b5a54368c1e696a8961a8e1de644feb21858e3c75ee4b5677583a8d2eed2ff7817fcfab083b9f97aef3 SHA512 20b0d4c820f6ec87bb441d0f35bdcd7bf78aa255e003d7fb572005fde38ec7576eb2aea38109494361162937fe063612f93e1ca97b822adc20c5e89252521b51
MISC metadata.xml 609 BLAKE2B 8f3429390129e4438c5bb4c8d82ae11e9824863d4b200a57d660d0ae93692711b96c6cbcfd9e7e8ad46848beba86dd2ee971acde59c08c9fc6f317283358157f SHA512 8a18175143b319bf6f623304ad8f534ad34eaf8b67c57ee1addb8886e34d79bd3a74723bce4f66fb5e9e3dad4768aaf253cec8fb8e97365f152d0b8f772d7df6
diff --git a/dev-python/pyxattr/pyxattr-0.6.1-r1.ebuild b/dev-python/pyxattr/pyxattr-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..5ce00c43a28a
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.6.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="https://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake doc
+}
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ local -x TEST_DIR="${TEST_DIR:-/var/tmp}"
+ # Ignore selinux attributes by default, bug #503946.
+ local -x TEST_IGNORE_XATTRS="${TEST_IGNORE_XATTRS:-security.selinux}"
+
+ einfo "Please note that the tests fail if xattrs are not supported"
+ einfo "by the filesystem used for ${TEST_DIR}."
+ einfo
+ einfo "The location for tests can be overriden using TEST_DIR variable:"
+ einfo " $ export TEST_DIR=/my/test/place"
+ einfo
+ einfo "Additionally, TEST_IGNORE_XATTRS can be set to control which"
+ einfo "external attributes are ignored by the tests."
+ einfo "See https://bugs.gentoo.org/503946 for details."
+ einfo
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}