summaryrefslogtreecommitdiff
path: root/dev-python/pywlroots/pywlroots-0.16.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 10:39:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 10:39:51 +0100
commit9b6120d8af003bb775da6737dfe42f8f580f59f6 (patch)
tree965a7890c4893d608fd8d3ce04030376ab565a45 /dev-python/pywlroots/pywlroots-0.16.4.ebuild
parent80765b090d10ae3f68b00e3befe5859f7212e536 (diff)
gentoo auto-resync : 15:07:2023 - 10:39:50
Diffstat (limited to 'dev-python/pywlroots/pywlroots-0.16.4.ebuild')
-rw-r--r--dev-python/pywlroots/pywlroots-0.16.4.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pywlroots/pywlroots-0.16.4.ebuild b/dev-python/pywlroots/pywlroots-0.16.4.ebuild
deleted file mode 100644
index 59ccc3eae06e..000000000000
--- a/dev-python/pywlroots/pywlroots-0.16.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python binding to the wlroots library using cffi"
-HOMEPAGE="
- https://github.com/flacjacket/pywlroots/
- https://pypi.org/project/pywlroots/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-# See README for wlroots dep
-DEPEND="
- $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- ' 'python*')
- >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
- >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
- =gui-libs/wlroots-$(ver_cut 1-2)*:=
-"
-RDEPEND="
- ${DEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf wlroots || die
- epytest
-}