summaryrefslogtreecommitdiff
path: root/dev-python/pywebdav
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pywebdav
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pywebdav')
-rw-r--r--dev-python/pywebdav/Manifest3
-rw-r--r--dev-python/pywebdav/metadata.xml14
-rw-r--r--dev-python/pywebdav/pywebdav-0.9.8-r1.ebuild29
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pywebdav/Manifest b/dev-python/pywebdav/Manifest
new file mode 100644
index 000000000000..40e07a8adf0c
--- /dev/null
+++ b/dev-python/pywebdav/Manifest
@@ -0,0 +1,3 @@
+DIST PyWebDAV-0.9.8.tar.gz 52605 BLAKE2B dcc52fa44f0a826247ec967f17eb4b6792960a6849c91f506a449a4a8531a8cff42aad3483d80d99bd5750049b1cf59c0554636e19dae2a480257d7e644bf4a9 SHA512 a920e63f1241e41acd7cf02f342fc81e321c50866b103690eee3352de3b0d51c0c9473079bb639d65402719158c6c8113b2c1b7e0bfdc0b863ceb290bcde0145
+EBUILD pywebdav-0.9.8-r1.ebuild 629 BLAKE2B 79e7f5e12b80d24e25e31706265fea4b705dba2e35231ecab54b8a2cef604cfc3a5864814d783caaa806d690df990f9ba70621660e8b837b76e23d8b327cd8d0 SHA512 89b8b2fd1af124e79be3478e54940e0bad47ebce36c66fb3f5c0877e18a79aebb8ef9b04efe77f85faee560a82f8687285fb20c9ba7a69c7b2f839b9707cca50
+MISC metadata.xml 548 BLAKE2B aff3d08253047bd7364658b7b6abc14e18cbd2c5ce588759401cc384b24065a46d6667f668ee361817834395cfa3284155f0cd684f4703c677995765e74d535f SHA512 572eea872363c2c2a66073208030f1178d75d15d7fc24b947a34c5253059e44acf7a9b0697c6bda24887d2933c7bd7b7fa870bebbdf34a8bfa2bc1191eb60941
diff --git a/dev-python/pywebdav/metadata.xml b/dev-python/pywebdav/metadata.xml
new file mode 100644
index 000000000000..e1e4449e832f
--- /dev/null
+++ b/dev-python/pywebdav/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">A WebDAV server implementation in python. It's aim is to provide a
+ simple interface to webdav services to any application which needs it.
+ It can be run as a daemon on *nix systems</longdescription>
+ <upstream>
+ <remote-id type="google-code">pywebdav</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywebdav/pywebdav-0.9.8-r1.ebuild b/dev-python/pywebdav/pywebdav-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..ac2511bd0e0a
--- /dev/null
+++ b/dev-python/pywebdav/pywebdav-0.9.8-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P=${P/pywebdav/PyWebDAV}
+
+DESCRIPTION="WebDAV server written in Python"
+HOMEPAGE="https://pypi.org/project/PyWebDAV/"
+SRC_URI="https://pywebdav.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/{ARCHITECTURE,Changes,TODO,interface_class,walker}
+}