summaryrefslogtreecommitdiff
path: root/dev-python/pywayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-12 11:46:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-12 11:46:20 +0000
commitaf42afeb201514cfc34a8a056def3389af35a54b (patch)
treedc183d93580761fd7e856068e25c046c6a53396d /dev-python/pywayland
parent26c687603afd123f35f1b8745cb38493a4e7d928 (diff)
gentoo auto-resync : 12:01:2023 - 11:46:19
Diffstat (limited to 'dev-python/pywayland')
-rw-r--r--dev-python/pywayland/Manifest3
-rw-r--r--dev-python/pywayland/metadata.xml11
-rw-r--r--dev-python/pywayland/pywayland-0.4.15.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pywayland/Manifest b/dev-python/pywayland/Manifest
new file mode 100644
index 000000000000..884ec2b1652a
--- /dev/null
+++ b/dev-python/pywayland/Manifest
@@ -0,0 +1,3 @@
+DIST pywayland-0.4.15.gh.tar.gz 61084 BLAKE2B 2417aa57942f5a7810db3525d16070ed81613bd1ab8f864a95e9f1835f9793348ad1afd2dbaeed2bb08f5bcb58777ab545f8ef7cb70903703c89998095724f8c SHA512 c45d2a24c487cf1785b7bc488808157e2dcae630438c289864df615c98278e7c03de21431fa622e0917713130f5583ff5cb3181c0a7f595cebba2cdeec36a7cf
+EBUILD pywayland-0.4.15.ebuild 936 BLAKE2B b6d8ee1088f580b4b4ae8cb5eacad3181e503744222caccae7527770f2411c9836ab884fb79c905286f8a06e8db8f1280589f86946e1af260653b5c1329c61cf SHA512 9179f1061403f243793e6f496b32718693065f883fefbee9a8eca3ce729cf531e15f530dd63806451367dd548d5da55d10cc4eefcf78b8ed4a726f122e8ceaec
+MISC metadata.xml 351 BLAKE2B 51bf5663be6335bdc8644039f9a4b8e20a0304495bfe6a3cce703766f41636b0d9ee9dfe490b0ea695f68f34a20dfe8097d5872b56cda0c721baf2488dc8ddce SHA512 7b6c3e8c6125ddcf660cc0518de7d0887db40424bf5ed02e892d871cfb2fb0786dcf14bcab38b277528ac0aa454f483508e4c0b22c90799c6fc3526f33abd5a4
diff --git a/dev-python/pywayland/metadata.xml b/dev-python/pywayland/metadata.xml
new file mode 100644
index 000000000000..028246926f40
--- /dev/null
+++ b/dev-python/pywayland/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">flacjacket/pywayland</remote-id>
+ <remote-id type="pypi">pywayland</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywayland/pywayland-0.4.15.ebuild b/dev-python/pywayland/pywayland-0.4.15.ebuild
new file mode 100644
index 000000000000..66023d87ae1f
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/wayland
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-libs/wayland-protocols"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -r pywayland
+
+ epytest
+}