summaryrefslogtreecommitdiff
path: root/dev-python/pywayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
commita519cf56a0e5e456006d39c06f68de5e11c2f7e9 (patch)
treeeb3511664a62de4a02ec7f25a9a3935956e288ab /dev-python/pywayland
parentd63d16d19ab9b58260753953a431d39230f2c362 (diff)
gentoo auto-resync : 07:10:2023 - 12:00:01
Diffstat (limited to 'dev-python/pywayland')
-rw-r--r--dev-python/pywayland/Manifest2
-rw-r--r--dev-python/pywayland/pywayland-0.4.17.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pywayland/Manifest b/dev-python/pywayland/Manifest
index 3bb6f100180a..96daf524ce53 100644
--- a/dev-python/pywayland/Manifest
+++ b/dev-python/pywayland/Manifest
@@ -1,3 +1,5 @@
DIST pywayland-0.4.16.gh.tar.gz 61058 BLAKE2B 4b299fe1b3067e2e222012db921b4ae5fdfd103b0ca2b796522236b6b8b2ffc1e54ba8c97d30970cb5df35c9da18ca217ea5d97a37b11d7112d93c59a1df164f SHA512 1098e0ae88ffc874d1e49f6441f06db05d1bfebead06d65e1214d69542b9ada0ec45bfccd6fd11dd188b2ebcf3d0ac2a2370927af8a0838f4e683ec50fc5e01a
+DIST pywayland-0.4.17.gh.tar.gz 61171 BLAKE2B f190107ab361ec9c0a568d22a104fa06a7e52a348a6226c30c2ae542b77e5b21b4a389ad745efb864b58cff9e77cb22ff43fd6614859cb138d398a84b99614a5 SHA512 9ca1e30b56f6d1447744451d15d84041d5ce6ce64811ca0e395822731f0c7cd1d8571f640b89771d8f5e9da1d82385734974e10e68ccecffc0f9600a83d2478b
EBUILD pywayland-0.4.16.ebuild 1084 BLAKE2B d9e2e3b2cb74e80d0c4f787f7930ed5c48a9fa2743003f58c9f840d3b716c54c53253ef0172451eb4644be1dc65ce3b9a80a8db6a60819770d0cc533268221fd SHA512 d01d15fdf0cf7f5d7ab71738df751d4953b58faceda466e450c42d7273d743cd865968cc22979decbb90e026954cea9c58c9c7bc23afa719a1021a3e38f819ae
+EBUILD pywayland-0.4.17.ebuild 1085 BLAKE2B 502c743718b03b21bf20e697f18d25ef8102cec757ae86c9ab7a987a0c538d81f19d6536044430329c1bce6fc4678f926867bae24a9f85fb00784c6d432b78f0 SHA512 2690503065aac0e1e976f4e8e218143ea9c296610f70965a686c4cbd99a23c8ddd866361c493411a06d641cc0a402d9eb6e690f9519b219c82918029d5b5afe1
MISC metadata.xml 351 BLAKE2B 51bf5663be6335bdc8644039f9a4b8e20a0304495bfe6a3cce703766f41636b0d9ee9dfe490b0ea695f68f34a20dfe8097d5872b56cda0c721baf2488dc8ddce SHA512 7b6c3e8c6125ddcf660cc0518de7d0887db40424bf5ed02e892d871cfb2fb0786dcf14bcab38b277528ac0aa454f483508e4c0b22c90799c6fc3526f33abd5a4
diff --git a/dev-python/pywayland/pywayland-0.4.17.ebuild b/dev-python/pywayland/pywayland-0.4.17.ebuild
new file mode 100644
index 000000000000..3741622e025e
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.17.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -rf pywayland || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}