summaryrefslogtreecommitdiff
path: root/dev-python/pyvtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyvtk
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyvtk')
-rw-r--r--dev-python/pyvtk/Manifest4
-rw-r--r--dev-python/pyvtk/files/pyvtk-0.4.74.patch20
-rw-r--r--dev-python/pyvtk/metadata.xml8
-rw-r--r--dev-python/pyvtk/pyvtk-0.4.74.ebuild23
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pyvtk/Manifest b/dev-python/pyvtk/Manifest
new file mode 100644
index 000000000000..740080ab49ef
--- /dev/null
+++ b/dev-python/pyvtk/Manifest
@@ -0,0 +1,4 @@
+AUX pyvtk-0.4.74.patch 972 BLAKE2B 8639554b46a894b34acf016c422aaf9c310ed08438d2c9396de68400d4ebff4079d11676cf07ddb7f000dc496c5a57dfd77a9f6e849b9745f8a144892855add3 SHA512 697f38b9df00528ef1e82fe8302901b92a6f2ff4e38af1bdb45e8c47821b13248a0c79dabfa485eaf2e9b9fa256fac96381e8dcfa76f364e2a8b1a94beecda91
+DIST PyVTK-0.4.74.tar.gz 25700 BLAKE2B b1eef6b632d2a0eb9c8b8327a2922c40ef7ab077fb42aa6f7f3f2d5a7e0f182b78ac77ace38b3ef33cf9068f322534354d774fa29fc97d51bf1d9b7f3289cedb SHA512 c3b29dd067339c1708f9757b83a127cbe008b291265181272b69a85c0348bc1388c4914acc24efdefda0421a601eede10af762753e683fbd0518361035313098
+EBUILD pyvtk-0.4.74.ebuild 477 BLAKE2B ee2057a2adb70ddbd09a8df84c070210ebe23acbd447e0fb2abb74da377b4c7a246f055d04f76ac5982df324714ca31968c7ab21c68155311b5de790c1565ad2 SHA512 80661d3c0efa07f4e1b146b6cc81d295f23d6e52d677751f3f6ccf1120fd6a18b65fc786c51eb5ae96930f9ea2901f9cc4e18dfc53c3e5c24b68f924e3ca754c
+MISC metadata.xml 259 BLAKE2B dfc879984b6adce945d0e0a50f6ede2bca87147b9db99491359cdeccc2e74a20d56e14ae8903dbb80c94854f89bee539f14a4e3ce864204e277accf3f124a748 SHA512 19fb78cf4029c154954a40df40e28fc8d98a8b7e6b42f97259f664d44c29b284feffb9d073cadc7f90b5654a64b2466e186cb677d3a11830206f173eb9057706
diff --git a/dev-python/pyvtk/files/pyvtk-0.4.74.patch b/dev-python/pyvtk/files/pyvtk-0.4.74.patch
new file mode 100644
index 000000000000..651c1f5ec37c
--- /dev/null
+++ b/dev-python/pyvtk/files/pyvtk-0.4.74.patch
@@ -0,0 +1,20 @@
+--- PyVTK-0.4.74/lib/__init__.py 2003-04-07 16:56:08.000000000 +0200
++++ PyVTK-0.4.74/lib/__init__.py 2008-12-03 18:08:35.000000000 +0100
+@@ -202,7 +202,7 @@
+ #print 'Reading file',`filename`
+ f = open(filename,'rb')
+ l = f.readline()
+- if not l.strip().replace(' ','').lower() == '#vtkdatafileversion2.0':
++ if not l.strip()[-3:] == '1.0' and not l.strip()[-3:] == '2.0' and not l.strip()[-3:] == '3.0':
+ raise TypeError, 'File '+`filename`+' is not VTK 2.0 format'
+ self.header = f.readline().rstrip()
+ format = f.readline().strip().lower()
+@@ -222,7 +222,7 @@
+ for i in range(2):
+ if only_structure: break
+ if not l: break
+- l = [s.strip() for s in l.lower().split(' ')]
++ l = [s.strip() for s in l.lower().split()]
+ assert len(l)==2 and l[0] in ['cell_data','point_data'], l[0]
+ data = l[0]
+ n = eval(l[1])
diff --git a/dev-python/pyvtk/metadata.xml b/dev-python/pyvtk/metadata.xml
new file mode 100644
index 000000000000..8425c0d53cb0
--- /dev/null
+++ b/dev-python/pyvtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyvtk/pyvtk-0.4.74.ebuild b/dev-python/pyvtk/pyvtk-0.4.74.ebuild
new file mode 100644
index 000000000000..84c5a47a2357
--- /dev/null
+++ b/dev-python/pyvtk/pyvtk-0.4.74.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P=PyVTK-${PV}
+
+DESCRIPTION="Tools for manipulating VTK files in Python"
+HOMEPAGE="http://cens.ioc.ee/projects/pyvtk/"
+SRC_URI="http://cens.ioc.ee/projects/pyvtk/rel-0.x/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}.patch )