summaryrefslogtreecommitdiff
path: root/dev-python/pyutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyutil
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyutil')
-rw-r--r--dev-python/pyutil/Manifest3
-rw-r--r--dev-python/pyutil/metadata.xml22
-rw-r--r--dev-python/pyutil/pyutil-2.0.0.ebuild26
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyutil/Manifest b/dev-python/pyutil/Manifest
new file mode 100644
index 000000000000..70320291b032
--- /dev/null
+++ b/dev-python/pyutil/Manifest
@@ -0,0 +1,3 @@
+DIST pyutil-2.0.0.tar.gz 125079 BLAKE2B cac7ce94671dbb2b4070aac76da2d9f8b3a48640a2422e8f9fd0dbd6a61eee43636b9b8a003ee3c528ffa7e866baf0254c4a2369ba8038c63aa072e2df9556ac SHA512 3704c028fdc3894ae635dabd2bace1af1e805f4158dc6d67eac0c38fa8e7959cd093ad39cb2f539e59dd74e957947464cc8c7aed727835e127311062ed27e60b
+EBUILD pyutil-2.0.0.ebuild 644 BLAKE2B 47eaca54d26ad3da866e16e369f58de07bd9b206227f5d39f7f42d01fef18c27cccd07c6d772478476a5018c43753139b857788337a50e111c3af172b7f2c228 SHA512 8a6520c84e5f90543f19d4f412fcc3440239747bbb001e43ceedabf0d87f57d472788532ad0e33612d7bfa26258e7fa04b6b9c5f8f9761d6fde4ad2757952d7c
+MISC metadata.xml 744 BLAKE2B 92a7150e6ded208271a22f52fcee0d6402006ee4a71e97236652485aace07d35eaeb4094e6ab9ed6ae197fa91d4f5f6236f4e591ffb1ee3270e22bbbfce1e641 SHA512 a23c7e3e981737b2a5952cf4ae5fb5017e68c68ded1d2e2dc534cfe630aa95dbe8b32c6fc784cb2a5744d66e91131f97a5c201029df04122cb1ac230a0bd0746
diff --git a/dev-python/pyutil/metadata.xml b/dev-python/pyutil/metadata.xml
new file mode 100644
index 000000000000..5d4021ab5e7d
--- /dev/null
+++ b/dev-python/pyutil/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ pyutil -- a library of useful Python functions and classes
+ ==========================================================
+
+ Many of these utilities (or their ancestors) were developed for
+ the Mojo
+ Nation, Mnet, Allmydata.com "Mountain View", Tahoe-LAFS, or
+ SimpleGeo's
+ products. (In the case where the code was developed for a
+ for-profit
+ company, the copyright holder donated the pyutil code to the
+ public under
+ these open source licences.)
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyutil</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyutil/pyutil-2.0.0.ebuild b/dev-python/pyutil/pyutil-2.0.0.ebuild
new file mode 100644
index 000000000000..64fccd9672e4
--- /dev/null
+++ b/dev-python/pyutil/pyutil-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities for Python programmers"
+HOMEPAGE="https://tahoe-lafs.org/trac/pyutil https://pypi.org/project/pyutil/"
+SRC_URI="mirror://pypi/p/pyutil/pyutil-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${ED%/}"/usr/share/doc/${PN}
+}