summaryrefslogtreecommitdiff
path: root/dev-python/pyupgrade/pyupgrade-3.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-03 11:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-03 11:48:34 +0100
commit8e3f5a0e42ba2822463660764321da4ed3b52ef9 (patch)
tree592fbe4efd697b02230386727643ed18f3da6a7f /dev-python/pyupgrade/pyupgrade-3.14.0.ebuild
parentb2b21ac05f4c298db348c97a3566bcf712492610 (diff)
gentoo auto-resync : 03:10:2023 - 11:48:34
Diffstat (limited to 'dev-python/pyupgrade/pyupgrade-3.14.0.ebuild')
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.14.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/pyupgrade-3.14.0.ebuild b/dev-python/pyupgrade/pyupgrade-3.14.0.ebuild
new file mode 100644
index 000000000000..19a841ef7eff
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/tokenize-rt-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest