summaryrefslogtreecommitdiff
path: root/dev-python/pyudev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /dev-python/pyudev
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'dev-python/pyudev')
-rw-r--r--dev-python/pyudev/Manifest2
-rw-r--r--dev-python/pyudev/pyudev-0.24.1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pyudev/Manifest b/dev-python/pyudev/Manifest
index 8b3cd8bd13c2..94292b8e4227 100644
--- a/dev-python/pyudev/Manifest
+++ b/dev-python/pyudev/Manifest
@@ -1,3 +1,5 @@
DIST pyudev-0.24.0.tar.gz 85887 BLAKE2B 82f23a1bbcd8ce5dd9e6f0551d967e7209067541185410668944734a5f0e17a907d6143cee81decb868d64cf8a0fe642dba7dc600f5ae3f03d9487f882d0aef3 SHA512 c711053a58cd857aff9e1df116ff11cfc17426d9f5a092810403150bec36239213a87b428bc31ec862b75b64a027f2d21081e15f76d914b67a9ddf39b0b73379
+DIST pyudev-0.24.1.tar.gz 85963 BLAKE2B 86c6d04691c99671735915564f58b4ef892e45925047487500bc7005343db7145941dde270f4ce9279881bd9bbf203965082d54b34b396febff52f387a1c26ac SHA512 10e32d9a74884000fbf8b86bee60530f6e7b936b990e7ae3b76099ace71834602de404721101c1076ef57365622a9a8f4819d57f58508ced09a21b7d50326886
EBUILD pyudev-0.24.0.ebuild 1330 BLAKE2B 3e5a9d474b12f171350d7a811dbab69aa10a82f72cf40fb5a48817acff512592cf986f64f5f75d244d0da286527ed66dca19c06c98b5edc80694858ac2e1d061 SHA512 cd4a7fbbe6ad16e9eaa7bedeb755483a676f4843dc27b4ce6265a7f343fdca4e4b41f917b37289aa9a524299b2b29909510b41284125fcbebc22c3f406593574
+EBUILD pyudev-0.24.1.ebuild 1337 BLAKE2B 2cd896723e5b86eec4a48a5e3c9a65655d1d5f2ccfcf0a3f6c140def8f6e2ed7878c39afccd3c5b9ce394a7a3f426f13d95b8e55c63d45b614d15d423dbcedb7 SHA512 dfb9466b70006e79863805c8cf5f4f288085429d9c984fca21561b653c024cadab1bba753751b4bbd95e3bbc9bae25da430b4f5e8b4f73526c532b86c024442e
MISC metadata.xml 705 BLAKE2B 5668637e59e1d434d0a72d0856e7ed614a2f5a3371e3fa4e841f4d516228f8b8a5567bc6a91cb07c8ee1f9c14db76ce238adac5bdab987a810adc2aed994b5a7 SHA512 a73f8225942c597d02ed08d3dc03724858f33cc07a2d9fcde64fe20f5c4263d1b7510e26e6365af120b72e7c8ebb075b7606dde493fe6464db2a585a23ca4b6a
diff --git a/dev-python/pyudev/pyudev-0.24.1.ebuild b/dev-python/pyudev/pyudev-0.24.1.ebuild
new file mode 100644
index 000000000000..e1c823ec5738
--- /dev/null
+++ b/dev-python/pyudev/pyudev-0.24.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python binding to libudev"
+HOMEPAGE="https://pyudev.readthedocs.io/en/latest/ https://github.com/pyudev/pyudev"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="qt5"
+
+# Known to fail on test system that aren't exactly the same devices as on CI
+RESTRICT="test"
+
+RDEPEND="virtual/udev"
+BDEPEND="
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test; then
+ ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
+ ewarn "change it to /var/tmp to ensure tests will pass."
+ fi
+
+ # tests are known to pass then fail on alternate runs
+ # tests: fix run_path
+ sed -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
+ -i tests/test_core.py || die
+
+ # disable usage of hypothesis timeouts (too short)
+ sed -e '/@settings/s/(/(deadline=None,/' -i tests{,/_device_tests}/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "PyQt5 bindings" "dev-python/PyQt5"
+}