summaryrefslogtreecommitdiff
path: root/dev-python/pytz_deprecation_shim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pytz_deprecation_shim
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pytz_deprecation_shim')
-rw-r--r--dev-python/pytz_deprecation_shim/Manifest3
-rw-r--r--dev-python/pytz_deprecation_shim/metadata.xml13
-rw-r--r--dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytz_deprecation_shim/Manifest b/dev-python/pytz_deprecation_shim/Manifest
new file mode 100644
index 000000000000..f994705dcfe5
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/Manifest
@@ -0,0 +1,3 @@
+DIST pytz_deprecation_shim-0.1.0.post0.tar.gz 60190 BLAKE2B a6d186ca6fff17a3fb787ad6164fcf45fbac272e6123491a6822699cf54a115c9941f2b1ee3d227f531a0ab1d11846300dc24974611cc1671c77405606704754 SHA512 201eea777f4da9def1b060911da5eaa89652f6716d5608278fdc94a2f67af5ea23a8b667cb181e03d5edd7f0a07f4954047621668f4c2e7bb325dd07f454d0b6
+EBUILD pytz_deprecation_shim-0.1.0_p0.ebuild 896 BLAKE2B c2d81913165a7292f90834ff7e830c265c103abded56f64ec1a6d0f2119e0129846b5a9c716c9352fe38bfc87652c79b5fa76a1d85c2ea42ff395a26b45d1e3f SHA512 5f12024b2a804a4e65ab2fc9b7172c927b70f9749d839655f60234844baf35a2ed4116e7eebff27ec6dd4c93ed16a58007154188a993e1f3d6992792e3e098b7
+MISC metadata.xml 419 BLAKE2B 2840524ff112ed60eeca8162297a1d4c0c3ecb47a5abaa440d237832f90a823789f07400200d2a0d31b25f6d2484a85d448549f32ccd7b4a1d755ff263c7df7b SHA512 3c75ed2c66ae13d4f67d50f07eb5e17fea8d4f8a3252d3a4d52ebe0c688c9253c61dc065ac6cda6120909e625fc1b6eb74a6f2d7dfc8cf25c8aed075a4f75bbc
diff --git a/dev-python/pytz_deprecation_shim/metadata.xml b/dev-python/pytz_deprecation_shim/metadata.xml
new file mode 100644
index 000000000000..12126b02ffe2
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytz-deprecation-shim</remote-id>
+ <remote-id type="github">pganssle/pytz-deprecation-shim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild b/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
new file mode 100644
index 000000000000..28c95ccfeac2
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+
+DESCRIPTION="Shims to make deprecation of pytz easier"
+HOMEPAGE="https://pypi.org/project/pytz-deprecation-shim/ https://github.com/pganssle/pytz-deprecation-shim"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytzdata[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme