summaryrefslogtreecommitdiff
path: root/dev-python/pytools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-19 07:50:17 +0100
commit262a170a603cee433f640577f13472ab41a5d3aa (patch)
treec8cd6d9417b8a1f2275883279d2ceaedba7207f3 /dev-python/pytools
parent37cd441738bc6681ca075c01b6dd06056a27abbf (diff)
gentoo auto-resync : 19:06:2023 - 07:50:17
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest2
-rw-r--r--dev-python/pytools/pytools-2023.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 966ff36d2609..9a0540a66922 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1,3 +1,5 @@
DIST pytools-2022.1.14.tar.gz 74636 BLAKE2B 5f3014c0adef3571c22b93c1dec1e4b49d48a0a0b9d320e7fa8f9712aaad04383222814770ab324b7d6e028d4b2a94698e6ea1f2f7fb89a654d7c8b371634dc7 SHA512 3e733d54176b135b69ac9c76ac7816463c5c874f3e1cede522ab2901250822c821fd325d0d2e5f2b124aeabb93386d8c68e3c6e1b11f6119bed7953ec80f9d4d
+DIST pytools-2023.1.tar.gz 75361 BLAKE2B 79c3439587624e9d236e6afd8ab2effa66ebc18c5f297db6bfebaf40dbe139de4851fa29d7741b064260041491a6693201583186a361994a8997eaaa221fffb2 SHA512 1d035f8b5e155def84d084926ab43b7e4c634cf7b2cd3e3914513360570bf87da059c8109e0257797dbe84c4bc36af559c805b252c863f2145113ff681eb5974
EBUILD pytools-2022.1.14.ebuild 825 BLAKE2B c759a9bebfbe22a55de1ac28f5510dd30186ec730bfe646f99e8efee9ec72feb83eeb512925d098a7672c4d8305f404736e930aed9e4289f7d80573d96eb7cca SHA512 3181ff706eae2499ea353ad3cb7d10aeb68fbba3b2c9fd8e01792afa9432a49b2c6f432c26e75686469e8668448409f26a96cb0838c9b882724a10d3eb11d795
+EBUILD pytools-2023.1.ebuild 827 BLAKE2B 7faba0a5d63e195f3fcf134a93c8dde721b86f230e33ce3b2530d743893232405d5ac8eddc20575a2d0b476e279cd01b5822aec15c89fbab4f705d0d31810519 SHA512 7bfb1fe916643346797bb42fd44ce305103846799b19da8da7270ef547b6e27e81eb977be29dfba54337c730a93368864e82f46c737148267d356134bb0e7e52
MISC metadata.xml 496 BLAKE2B d0067ed5726907ed3d635fc88dc33722335e7c853ee4a5a1c727faecdf6a78ab7de4261fe40c5c903908e1f2b8eb597ff3c014044fc7ea02bc357254d544da64 SHA512 c6b546564e9c54bccc55f83310ff194192be0673bfe552e18e29a82e87d2caf4c0d51e42d1675cf5b8f6dff1fa1410676f71c9c0c56273ba6efc4efc608c43d9
diff --git a/dev-python/pytools/pytools-2023.1.ebuild b/dev-python/pytools/pytools-2023.1.ebuild
new file mode 100644
index 000000000000..a0307d3d551f
--- /dev/null
+++ b/dev-python/pytools/pytools-2023.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest