summaryrefslogtreecommitdiff
path: root/dev-python/pytools/pytools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytools/pytools-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytools/pytools-9999.ebuild')
-rw-r--r--dev-python/pytools/pytools-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytools/pytools-9999.ebuild b/dev-python/pytools/pytools-9999.ebuild
new file mode 100644
index 000000000000..20b83f7f35d8
--- /dev/null
+++ b/dev-python/pytools/pytools-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A collection of tools missing from the Python standard library"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+EGIT_REPO_URI="https://github.com/inducer/pytools"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}