summaryrefslogtreecommitdiff
path: root/dev-python/pytools/pytools-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pytools/pytools-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pytools/pytools-9999.ebuild')
-rw-r--r--dev-python/pytools/pytools-9999.ebuild27
1 files changed, 7 insertions, 20 deletions
diff --git a/dev-python/pytools/pytools-9999.ebuild b/dev-python/pytools/pytools-9999.ebuild
index 765b22bf080c..618ec9fc5a6d 100644
--- a/dev-python/pytools/pytools-9999.ebuild
+++ b/dev-python/pytools/pytools-9999.ebuild
@@ -1,37 +1,24 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE='sqlite'
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1 git-r3
-DESCRIPTION="A collection of tools missing from the Python standard library"
+DESCRIPTION="Collection of tools missing from the Python standard library"
HOMEPAGE="https://mathema.tician.de/software/pytools/"
EGIT_REPO_URI="https://github.com/inducer/pytools"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
>=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]"
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest