summaryrefslogtreecommitdiff
path: root/dev-python/pytidylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pytidylib
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pytidylib')
-rw-r--r--dev-python/pytidylib/Manifest1
-rw-r--r--dev-python/pytidylib/pytidylib-0.3.2-r2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytidylib/Manifest b/dev-python/pytidylib/Manifest
index 20c32fb7bcd7..e9e5e653a511 100644
--- a/dev-python/pytidylib/Manifest
+++ b/dev-python/pytidylib/Manifest
@@ -1,3 +1,4 @@
DIST pytidylib-0.3.2.tar.gz 87669 BLAKE2B 57eee794e3a6ba147b778360a12d2417c21579250620854267a83300d918cac0320c768faacb531517b66eed7fd7afc1679e76f2db626f7d7daa80af1667a06d SHA512 24f755ed2607e300711f5a1aee510df3a0a410cc7d8d8f46e065ec8d93c50e436a492cc2831e9d416ab9837497c603f9dc8705da543102813d3264e6de033ca7
EBUILD pytidylib-0.3.2-r1.ebuild 598 BLAKE2B b651fd69fec5b94be9abf4844a627e27605f220baf90cc290796790d24776fa8fa4072b2f421e119b381fc0a81270e70d61006b7bd94f855655b9b9053dd8bf7 SHA512 622719a27ec15e1a9eaf977032a6b47679797ceb273abf4083c36b7e626f34a10a67339e64360f8fadc9234909471d1b66338bb4b9a30996f13848b65859ffc0
+EBUILD pytidylib-0.3.2-r2.ebuild 610 BLAKE2B 963bc0880411921d8f71e7b7801341b6906f61b40ace2d4345b6ec0a9a1a7953c863a2bf637cef4ea2647aac604307c784fd538c529d0bff0b99a5ef7db5bf2a SHA512 d9386883d3b856ce18bef63b2992f3e2756e1358c51dc6ed56c7f8ee1c282447daadadce5d9a21094be4fa2d103fa8065bfdbe2b72bbf1e0b227c5ee99f2193b
MISC metadata.xml 386 BLAKE2B 827fbfb2980cea331345e42992787858b4bfa481157841c2a6970d75e4a5d669e864e545c07723baa5fd673d7fac020fa8ed26008e57064e3de4b230809ac358 SHA512 88a181e7b71f76b1d0271362b39a7310ecf5cd90cf98aa41e609833cfae4c5886b6d4beb1fd387ca6aec3f7a9da1bdc9a1e3424b018039804049ed94b717f92c
diff --git a/dev-python/pytidylib/pytidylib-0.3.2-r2.ebuild b/dev-python/pytidylib/pytidylib-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..e142771152eb
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.3.2-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="app-text/htmltidy"
+DEPEND=${RDEPEND}
+
+distutils_enable_tests pytest