summaryrefslogtreecommitdiff
path: root/dev-python/pytidylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/pytidylib
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/pytidylib')
-rw-r--r--dev-python/pytidylib/Manifest2
-rw-r--r--dev-python/pytidylib/pytidylib-0.3.2.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytidylib/Manifest b/dev-python/pytidylib/Manifest
index 8d486b3736ac..240ee42728fc 100644
--- a/dev-python/pytidylib/Manifest
+++ b/dev-python/pytidylib/Manifest
@@ -1,3 +1,5 @@
DIST pytidylib-0.2.4.tar.gz 86650 BLAKE2B 15212651c83ebbec5b74418f37bfcd0366e9b6cdfc0820953e34ec3142871248df02618a51415a36b84ac8c2e5a12d996ff7301b5bf3a001fb42297df3a98202 SHA512 443e9af0fd458d4f041e3b72415839838a4edc83f8a978e5cc0bdf53202584e269f1ad5df10967d8ae4b98b24dcffcf9f5a54e0e3f6cd620a8a6a20171da0811
+DIST pytidylib-0.3.2.tar.gz 87669 BLAKE2B 57eee794e3a6ba147b778360a12d2417c21579250620854267a83300d918cac0320c768faacb531517b66eed7fd7afc1679e76f2db626f7d7daa80af1667a06d SHA512 24f755ed2607e300711f5a1aee510df3a0a410cc7d8d8f46e065ec8d93c50e436a492cc2831e9d416ab9837497c603f9dc8705da543102813d3264e6de033ca7
EBUILD pytidylib-0.2.4.ebuild 640 BLAKE2B 2592f38ce16cbcc65bf2a16741a4006a4d12b98e4140b7558539cbc4119e728ee27a5cf7df7045c1590e5097acc0998cbcfb4ca7f851ee5055888052362861f1 SHA512 c987bd0531902490041b112f875ea56241af8b9353238512f25319e816cf4837bd0903aeb9f77b21ed9841be2562b094fadf181468559c2f97e80d03cf228674
+EBUILD pytidylib-0.3.2.ebuild 690 BLAKE2B 5cced93a9713203f410d6a815e03427f1ee22e8f8527f7cf5401c389abd2f96faef20b62d1d2d0bad1f2c83d810d0c812bc3a76d12c113402b2a39b1c5264aae SHA512 597c124ec12bc4db696468e215996869bdbebccfcd3da0fa5dac467c3c5ad39bd1542e9c32751baa3b2dd34c50bb200a06d11b09ee7b1c8ba494847fa7eee2ae
MISC metadata.xml 385 BLAKE2B 6c53cf6462d81e85c2a9facf85c0fd7b6c0c870656fdc4cc63bcd67e646d51e14fc9246a7b75a527eccecaf4385677ea63b56dfa04aeab708b41b83c8bc4fcef SHA512 e41d4897a343c45e469fe4cd52a7ce93d525ea208dd570fe0517feda8f445fa9175d971e4c37b8f1941a7cb6931ff6473526ced82384489f02a11c4040fec933
diff --git a/dev-python/pytidylib/pytidylib-0.3.2.ebuild b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
new file mode 100644
index 000000000000..1edb2743c4b4
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="app-text/htmltidy
+ dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv || die
+}