summaryrefslogtreecommitdiff
path: root/dev-python/pythran
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-07 22:29:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-07 22:29:07 +0100
commitde1079fbccb3bceb32818385f756637e266f2107 (patch)
tree570d809a9fcbf27d05be1a94090b087521c5514b /dev-python/pythran
parent2cd907d16458ba3a99ec82155d7268e2d991a078 (diff)
gentoo auto-resync : 07:09:2023 - 22:29:07
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest2
-rw-r--r--dev-python/pythran/pythran-0.14.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 1b65b1d3a9f0..f3d4a2f17d15 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1,5 +1,7 @@
DIST pythran-0.12.2.gh.tar.gz 3631092 BLAKE2B 5c7c9aadd1351fbfd1368b2957ad5952338aaf41bc124caad4243538f325599d50eeda12383a41e2bff0245ab2ecda3a27254d98d3e09f929d3d28856d556cd3 SHA512 2f83a2cda04dbdf55dcb6f5f1f43e9bb39668fa9f568ed39760a360f59f65b1e7e1f313d26efcb530fad34e69cc8dfb5aa38747943daa8d06d00b2610a1a7be5
DIST pythran-0.13.1.gh.tar.gz 3639196 BLAKE2B 8aba73c68542d69dd2287d7081226161ecade9e49fe6ea69d034f9116becbc148614212cbcff0056291809d2994caf43ee374393939e44635c6bed69220b29b8 SHA512 2497fa49d78ff64e577816f4b48bd424c03f04b7605c92d359f0f8514aaa67b30b7e68248db475c215deafaf7e55f7b4b74ab37c9dbef2a27e813878bf350e77
+DIST pythran-0.14.0.gh.tar.gz 3642431 BLAKE2B cd5eeca0c52b0c3d17862b38c176b435a63a1f399e66979b8ac2682625cd0b0e074265e79bfdb6e57db989633954266132752e9b50c601ff43ae5c17c3e34bf5 SHA512 2a485c00b015abafc9ded28bfea8d8a7ae3ce87b5b654c318d5514fe12fd9374b599c05e3c4a2ff911fbae84df2efaa3cec2019c91e82ac1f36e0cc5ddeb2d8e
EBUILD pythran-0.12.2.ebuild 1533 BLAKE2B c0d06b33214d61e7f6e9699234dbdb2b62cbe7f8e7b8479f3f75317e2934942186ab14340e5153321e0a8266ee5ffccdff8b7de8673a899a538389c4eec5ba18 SHA512 28341e2f44a9107450872b476d1cd45a0e123faa8d3ce61b8dc8257e8f4035d0767b5d0277a6ca8abe1b7d17a8bea06e1f1a221a2d9401ffce746e8db339ca14
EBUILD pythran-0.13.1.ebuild 1716 BLAKE2B 43e2e3a4390b10627239e7a1143db7775d5355d7fa52effe0463412b8887121a6e49f6ce360e0d1c9989547f08f4e9743caebab853b7c7eb208b5ec2ccf12b8d SHA512 683183b48a35dc55b72976a83f2f2288e2dcf8391bcd12daba9b5bef40dd379d2aad22c1a403909a44f87a0705957e937d11338d9c26266369c8e5fc83cd6734
+EBUILD pythran-0.14.0.ebuild 1700 BLAKE2B 82f7c8557f52a78216e004833e26fa7be4465eb5dcc089827e0b362339be56e9b775620543e8b78cf7fa3cd7e88ffd7bec7b1afa07e8aa4e55d3d6409ea7adfc SHA512 b27f934fe0f91fc5abf00569ef704fb6aea30e65a3ea1ecc904843e7e4b26306934a7a46432b32279c7dd7ed7e63a6c093eaf8f8273cd335f56b05f3b0acb12f
MISC metadata.xml 354 BLAKE2B e7ec71fae294f6f697b0fd99b0ccef24049af7999866344e8da2ebc40bc2988a21f2cb0374b52b781a5f8b55f26ebca364dc93f4e69d957a3ff6bd3c32cd988d SHA512 9008d270ea6757557482edb55c5848aea9a29abfbbad65d93000660a1e51ad2456a2b7ccfcacb80da23b3dd38cee2c4da9645aed48a35edb4a497bbe3a80dd7f
diff --git a/dev-python/pythran/pythran-0.14.0.ebuild b/dev-python/pythran/pythran-0.14.0.ebuild
new file mode 100644
index 000000000000..7fa6c0f770cb
--- /dev/null
+++ b/dev-python/pythran/pythran-0.14.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..11} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/
+"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/boost
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-libs/boost
+ dev-cpp/xsimd
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ !!dev-python/setuptools-declarative-requirements
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ cat >> setup.cfg <<-EOF
+ [build_py]
+ no_boost = True
+ no_xsimd = True
+ EOF
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ pythran/tests/test_xdoc.py::TestDoctest::test_cli
+ pythran/tests/test_xdoc.py::TestDoctest::test_toolchain
+ # Tries to invoke pip
+ pythran/tests/test_distutils.py::TestDistutils::test_setup_build
+ pythran/tests/test_distutils.py::TestDistutils::test_setup_build2
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)"
+}