summaryrefslogtreecommitdiff
path: root/dev-python/pythran
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-28 07:59:59 +0100
commitb8325835c82367d22428eb41afa0f2d375338d3c (patch)
treec416b8853bd14fc346da5d0129843cc4a68a30a0 /dev-python/pythran
parentd2ed973482fdd800013658e83a61709b29e0a80f (diff)
gentoo auto-resync : 28:06:2024 - 07:59:59
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest2
-rw-r--r--dev-python/pythran/pythran-0.16.1.ebuild15
2 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 8368e847a6dd..76ba334e46df 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -3,5 +3,5 @@ DIST pythran-0.16.0.gh.tar.gz 3680823 BLAKE2B b0bd65b79831b2a64503d25a71b41ba493
DIST pythran-0.16.1.gh.tar.gz 3680817 BLAKE2B 2a4b928e9d0ce68248eb543c97da5afca900d81bc660377313617149c5aae7529a371bfd3604dd9feb6e38f834360fef881c8324ae72b585d8ab86e867c2f6b3 SHA512 7a89546b52bdae9bdaeba42768ac822c584a3714b8f4e32417d793454dc0b5492342dfd393d92f8ecee12c854bc39e418f5860aadd00d328afef7b17ebddec99
EBUILD pythran-0.15.0-r2.ebuild 1648 BLAKE2B e9e65a8dea0cf1d6e65c856f1c30b6dd829f577c5999213635a18d999c67eb7b0f3262b90af161469ee5e457c594105a0d0acf4a670859f4a56830575c2d458b SHA512 d3929d7707bf9a34f23dfc997d0cd71c588d34d980c04831ed7b08a0afb583b00408ee52fb72e742c48ed1e57909b9c07d5f0bf8926b86db5d91bd4c52a2705d
EBUILD pythran-0.16.0.ebuild 2791 BLAKE2B ab7878210f6ce5e05783dcd10e4719fa6ed0dd81d2e253f1ed752c2c6af4722ab236a1f99bdc45794b7f8cd1eced9b7e2c460dcc217d8a8ac63fa17ca47bcf30 SHA512 aa4ebb42acc9bfcc6bd6b4d2a3d3670fdf308e092107b0e57f1d822a57f1ff75dcc4e5e420d3e4ec8c3ef19a6ddd4cf7f8ab38cd15240a0f0bf3bc2ad1f2f530
-EBUILD pythran-0.16.1.ebuild 2873 BLAKE2B 024e98af35b3dee1b34b3dda999d9045f2679c52084eecd74af68366593f2a6c45ab90f977b7c95ab5d2a4a4dd5ed9328cd89826505a1be6494c1a84cb393722 SHA512 0722955a30a2f92f300d320a0109fd87c23370316e75e402330b036d6a3179ecbc76fc4b7fcd8baba10aa436d063c3528afa582bac78a74d973f3cb08b9b99b0
+EBUILD pythran-0.16.1.ebuild 3009 BLAKE2B 80f267199f511471c812e2a71c1ea973c6ab510d503fc8f7cebd01d839259ab9d31f03ccdacd18a20deb990c4423191aa15c3a611a721e3cb02772cc98121b54 SHA512 97ecee7eecefc2c95ef0833506a797303c6b124892fce30854439260e1ae2e47562cb1c1d584486169ed55b80cb949acb11ce43618c175737e0712752e6c3289
MISC metadata.xml 354 BLAKE2B e7ec71fae294f6f697b0fd99b0ccef24049af7999866344e8da2ebc40bc2988a21f2cb0374b52b781a5f8b55f26ebca364dc93f4e69d957a3ff6bd3c32cd988d SHA512 9008d270ea6757557482edb55c5848aea9a29abfbbad65d93000660a1e51ad2456a2b7ccfcacb80da23b3dd38cee2c4da9645aed48a35edb4a497bbe3a80dd7f
diff --git a/dev-python/pythran/pythran-0.16.1.ebuild b/dev-python/pythran/pythran-0.16.1.ebuild
index fe9595e00b3b..2e6579a35281 100644
--- a/dev-python/pythran/pythran-0.16.1.ebuild
+++ b/dev-python/pythran/pythran-0.16.1.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( pypy3 python3_{10..12} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1
@@ -44,10 +43,10 @@ BDEPEND="
test? (
$(python_gen_cond_dep '
dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
+ ' 3.{10..12})
+ dev-python/pip[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
virtual/cblas
!!dev-python/setuptools-declarative-requirements
@@ -97,6 +96,12 @@ python_test() {
pythran/tests/test_set.py::TestSet::test_fct_symmetric_difference_update
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # repr() differences?
+ pythran/tests/test_xdoc.py::TestDoctest::test_tutorial
+ pythran/tests/test_xdoc.py::TestDoctest::test_utils
+ )
esac
fi