summaryrefslogtreecommitdiff
path: root/dev-python/pythong/pythong-2.1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pythong/pythong-2.1.5-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pythong/pythong-2.1.5-r2.ebuild')
-rw-r--r--dev-python/pythong/pythong-2.1.5-r2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pythong/pythong-2.1.5-r2.ebuild b/dev-python/pythong/pythong-2.1.5-r2.ebuild
deleted file mode 100644
index fa40cbcd91b9..000000000000
--- a/dev-python/pythong/pythong-2.1.5-r2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="tk"
-
-inherit python-single-r1
-
-MY_PN="pythonG"
-MY_PV=${PV/_/-}
-MY_PV=${MY_PV//\./_}
-
-DESCRIPTION="Nice and powerful spanish development environment for Python"
-HOMEPAGE="http://www3.uji.es/~dllorens/PythonG/principal.html"
-SRC_URI="
- http://www3.uji.es/~dllorens/downloads/pythong/linux/${MY_PN}-${MY_PV}.tgz
- doc? ( http://marmota.act.uji.es/MTP/pdf/python.pdf )"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ia64 x86"
-SLOT="0"
-IUSE="doc"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-lang/tk-8.3.4:0=
- virtual/python-pmw[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
-src_prepare() {
- sed \
- -e "s:^\(fullpath = \).*:\1'$(python_get_sitedir)':" \
- -e "/^url_docFuncPG/s:'+fullpath+':/usr/share/doc/${PF}:" \
- -i pythong.py || die "sed in pythong.py failed"
-}
-
-src_install() {
- python_domodule modulepythong.py libpythong
- python_doscript pythong.py
-
- dodoc leeme.txt
- insinto /usr/share/doc/${PF}
- doins -r {LICENCIA,MANUAL,demos}
- rm -fr "${ED}/usr/share/doc/${PF}/demos/modulepythong.py" || die
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/python.pdf
- fi
- python_optimize
-}