summaryrefslogtreecommitdiff
path: root/dev-python/pythonfinder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 16:34:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 16:34:53 +0000
commitdfd7c8230bca447ee0b09dc11150181b0b3148e2 (patch)
tree11f7e2fe7599d1e364bdfb4176f2f41e99a3c603 /dev-python/pythonfinder
parentcd8b6c60f3cbb06647bf3d03fb2ac29ccfc31c8f (diff)
gentoo auto-resync : 14:11:2023 - 16:34:53
Diffstat (limited to 'dev-python/pythonfinder')
-rw-r--r--dev-python/pythonfinder/Manifest3
-rw-r--r--dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch38
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.0.6.ebuild35
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pythonfinder/Manifest b/dev-python/pythonfinder/Manifest
index 6fa5b636e74b..e5e649cfbb0c 100644
--- a/dev-python/pythonfinder/Manifest
+++ b/dev-python/pythonfinder/Manifest
@@ -1,4 +1,7 @@
AUX 2.0.5-fix-import-cached-property.patch 400 BLAKE2B 45f4cdab70100af434a4dc1df5b170ad13dafc915ab86db3b3ec1b5f617a8e926c1173d260bff4dd6553e4a9c289bff449a581add8d2b511b425135a342d0af7 SHA512 126230b303fbc083697a5f44ccdf45273a63e4f8652a997539ca3e1b48ad8a29921dcad9c30e9349ba3a58ec8dfa06a9c8c46ebd5ca53a46420ae8cc6ab2dedf
+AUX pythonfinder-2.0.6-pydantic-2.patch 1574 BLAKE2B 4c19ca86aca9967ec0a0f96c5c7e986322c16427fd073f5235367e6214acc06a45d4c4c3ffaf5fa5f166d0b1bf30b7f34058f9c87b2246dc4c27753b7a689c98 SHA512 b907e1d650704d3947eafa847efec95e77e089bdd2d53fe1e595aff85cdba9e7004e35a3b777e05054547920d5a7128ff6fb26673ff7dbf2ca722cd6d4e9393b
DIST pythonfinder-2.0.5.tar.gz 718776 BLAKE2B 32a49dbff143042554d5328b61b612e3bde7a870d53a229303b6bdd2c2ce76457bf6aadcdb215efa332407003c1319215292f3278a2808b669b5b7819af08902 SHA512 4d205c66d7ae36f4f2b8ddab9cce00f4efd5548a41d251470a515b88f8be2dcede75372b9301223822031ae663c6ccf77156531b0dd5d8972424f90641255c5b
+DIST pythonfinder-2.0.6.tar.gz 718821 BLAKE2B bc45c8ebffd4b8a21084c3b5f4d9cba71383613e6b25ec01ba53b0abf5d01cf78d1636b19c6c32f80eec401c56c25eedded793fabc46e2bbd389074a45ae14f5 SHA512 2aad884101d1a9fc1340fb63b11811aa7bd1c1f6d2945f9d133bb473099c7e11da21a4348ca742cae03a23fc8b12b85dcae4e9b3a2d29ec98530b6d8d2567d1c
EBUILD pythonfinder-2.0.5.ebuild 579 BLAKE2B 702f71d33e0f2a6d72cf3b2ba4c1ef78891d6d6b608a161705cc0aa982a14878f01832c4812deedd6b47019769d113e7045d8cdfa5354f934ea46e6120baacd4 SHA512 8b4aca37627ab11f394815ee7eaec785f78c8edec8c2c73f520c214d3e1b0e3990f915302b6296eda899323bf23af4ac7b2fbe586680797aed65afa23ba5defd
+EBUILD pythonfinder-2.0.6.ebuild 785 BLAKE2B 333d79d9ab39e73d05f99335490e4b3f8962f257d13bf538bf1b0f2e7346b676ad228fba3ad9760cd692cbe21e2ef9ef8589d0792f104a6aa5f0f096e2ac153c SHA512 4faf9f0d6f0d3b3c1c5b450f2ba75ce6f8ded3abe3e1ed9ef22fc165fac6f69e33ca9d45a30fa6da13296614a5bd685112c2d689bf42e65bed2213cd54281e6d
MISC metadata.xml 550 BLAKE2B d48667a74c94f5234a1b3ddff6521574aaa8b7cc441b1e206b35c67a7ef331a946de527d4f8edd20d45bda50a7f3067508ac8a60f052f44073d773f14584c01b SHA512 e2f86c14d0dd02fc51f10f078546c800201b43a8d3904dc763f5a35773e0ded146618885ccb9754d1404bea959098b6e4ea02a37fb96d9ebe7f705e26f36df37
diff --git a/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch b/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
new file mode 100644
index 000000000000..6b3840361bed
--- /dev/null
+++ b/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
@@ -0,0 +1,38 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 73a3c85..27c9a7e 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -39 +39 @@ dependencies = [
+- "pydantic>=1.10.7,<2",
++ "pydantic>=2",
+@@ -140 +140 @@ runtime-evaluated-base-classes = [
+- "pydantic.BaseModel",
++ "pydantic.v1.BaseModel",
+diff --git a/src/pythonfinder/models/common.py b/src/pythonfinder/models/common.py
+index 4c439c9..0ef3d77 100644
+--- a/src/pythonfinder/models/common.py
++++ b/src/pythonfinder/models/common.py
+@@ -3 +3 @@ from __future__ import annotations
+-from pydantic import BaseModel, Extra
++from pydantic.v1 import BaseModel, Extra
+diff --git a/src/pythonfinder/models/mixins.py b/src/pythonfinder/models/mixins.py
+index 58ce99a..e68020f 100644
+--- a/src/pythonfinder/models/mixins.py
++++ b/src/pythonfinder/models/mixins.py
+@@ -15 +15 @@ from typing import (
+-from pydantic import BaseModel, Field, validator
++from pydantic.v1 import BaseModel, Field, validator
+diff --git a/src/pythonfinder/models/path.py b/src/pythonfinder/models/path.py
+index fe98054..beb88be 100644
+--- a/src/pythonfinder/models/path.py
++++ b/src/pythonfinder/models/path.py
+@@ -26 +26 @@ else:
+-from pydantic import Field, root_validator
++from pydantic.v1 import Field, root_validator
+diff --git a/src/pythonfinder/models/python.py b/src/pythonfinder/models/python.py
+index c5e0345..32c82a8 100644
+--- a/src/pythonfinder/models/python.py
++++ b/src/pythonfinder/models/python.py
+@@ -22 +22 @@ from packaging.version import Version
+-from pydantic import Field, validator
++from pydantic.v1 import Field, validator
diff --git a/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild b/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
new file mode 100644
index 000000000000..344edd8900eb
--- /dev/null
+++ b/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
+HOMEPAGE="
+ https://github.com/sarugaku/pythonfinder/
+ https://pypi.org/project/pythonfinder/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # based on the patch from Arch
+ # https://gitlab.archlinux.org/archlinux/packaging/packages/python-pythonfinder/-/blob/main/python-pythonfinder-2.0.5-pydantic2.patch
+ "${FILESDIR}"/pythonfinder-2.0.6-pydantic-2.patch
+)
+
+python_test() {
+ epytest -o addopts=
+}