summaryrefslogtreecommitdiff
path: root/dev-python/python3-saml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
commitebadb1bcdd3c4fdd2e1a569a04d2cd8c5049b64d (patch)
tree261a9ff495381f4023c98dfb4ecd5cb195b5f346 /dev-python/python3-saml
parent2666e9c75caf914c25a25329523c982df8512930 (diff)
gentoo auto-resync : 28:12:2022 - 14:12:52
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest4
-rw-r--r--dev-python/python3-saml/metadata.xml2
-rw-r--r--dev-python/python3-saml/python3-saml-1.15.0.ebuild43
3 files changed, 47 insertions, 2 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
index c3768d6335a9..f59d5aa53d1e 100644
--- a/dev-python/python3-saml/Manifest
+++ b/dev-python/python3-saml/Manifest
@@ -1,3 +1,5 @@
DIST python3-saml-1.14.0.gh.tar.gz 510031 BLAKE2B 10c1102b29b58017a39241dbab7d2fb85231f051e3701ff24197f2e501ae19b1889d4032fe86a60ed5ee708380d44111dc6ab87900c8463a141ea911fe774eeb SHA512 6807a4741164dfdf185a4c63691d5a1f0e91feff387265dc8b54b135d44158c751c2274eb1f47eb71d61c7e233d38ddc83f34d092cb842676830699ad6ee8af4
+DIST python3-saml-1.15.0.gh.tar.gz 511199 BLAKE2B c1dafb5ff9c45a79042915261cdc380a1ca77b56d518999164f48c904e53a486d157e5b522b77df9abea2b3306f8b17a06a7ac3e41ad0c86bea2c08468199e60 SHA512 8ecfd827e3b90f65a04ed46f8efd49680d42ecaa46b46857e0f712c2996207a8aa38834f55ec35e599845f6921bd4d82d76e549494c71cc5ffd918e70b87b6a8
EBUILD python3-saml-1.14.0.ebuild 879 BLAKE2B 718e5388290ab913b43cd3d0505e790ae95802c56a9dc7cba0e8f3e072d58b2ef73864c07b639cc937a1656b868adc2248e3b82492fdaf9d90fe87c1f1e05b15 SHA512 c1a86aaf51f12e3d2e165171254dd256a14c20dfe6880085dbbf37698168f1784d7118cbd3e455211e546df1a1ac252dc567c8be0da04b82741e389d29620c4a
-MISC metadata.xml 487 BLAKE2B cc928de641a0bbd7e3de2b4d917853439ac6838b673c9aed83b5597d841d1df159474f4df5c48dce5d8e9cc95e5db5329fa4f4413f028cf49ac15b859f125164 SHA512 96c163d9e207ec64903025fcd4e425ad9e39099bae2349f44026cd668171965dc13033f34ded70d56af6f817f44eaf3ef3b67beeda207cc2f55a39cfab5541b0
+EBUILD python3-saml-1.15.0.ebuild 903 BLAKE2B c08f6ba6dd9958abf36988929946d76e44614f840b7f06e9a39c1d78a5d2e4f1c1094298b3bd00bf05ad6cf7881995e53de04f2478288523d1203ba51848a949 SHA512 aaa823f0a461fe4e34e2a29fda83f1abf494a286cb7049c59b2163594edf4c4d6d442f1cc8e95f8a37e24f9e87d93c8ae168c4c6522ed69e1800a05dca85c117
+MISC metadata.xml 492 BLAKE2B ca47379cffabb1ea29ebd103e865a37dd680753f1816fbc38796faea21611dd305a9b423f007d06b15a5dfb03a813feadef810a35b794912c5799eaa780a8ce5 SHA512 0954909199f1c46bdb35c8ad95794bdc8be1dbacd888809cc32b3404b2053cdc90aed275e5c51d6a4aad9a9b68d84e83749051c7117ac98cd12ef73331a8cd16
diff --git a/dev-python/python3-saml/metadata.xml b/dev-python/python3-saml/metadata.xml
index 2d72864bd0f7..a3b24bec325e 100644
--- a/dev-python/python3-saml/metadata.xml
+++ b/dev-python/python3-saml/metadata.xml
@@ -11,6 +11,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">python3-saml</remote-id>
- <remote-id type="github">onelogin/python3-saml</remote-id>
+ <remote-id type="github">SAML-Toolkits/python3-saml</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python3-saml/python3-saml-1.15.0.ebuild b/dev-python/python3-saml/python3-saml-1.15.0.ebuild
new file mode 100644
index 000000000000..e6ccb181054a
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.15.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="
+ https://github.com/SAML-Toolkits/python3-saml/
+ https://pypi.org/project/python3-saml/
+"
+SRC_URI="
+ https://github.com/SAML-Toolkits/python3-saml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmlsec-1.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # The tests are horribly fragile to paths.
+ local -x PYTHONPATH=src
+ eunittest -p '*_test.py'
+}