summaryrefslogtreecommitdiff
path: root/dev-python/python3-saml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/python3-saml
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest3
-rw-r--r--dev-python/python3-saml/metadata.xml8
-rw-r--r--dev-python/python3-saml/python3-saml-1.9.0.ebuild32
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
new file mode 100644
index 000000000000..6428c7a813a0
--- /dev/null
+++ b/dev-python/python3-saml/Manifest
@@ -0,0 +1,3 @@
+DIST python3-saml-1.9.0.tar.gz 497106 BLAKE2B c3b282be835dcd0590125563ed0380bbb5d486aeffd60fa0d6a1e7d22b25ffaa03a1bea555520b1465b27b352df0936d21b919ce73a3671d63f07a52b3efdb37 SHA512 a5171258b917c02f10a0c420a19fe6829a034df1dfd87135351b9c187314dca2f973012f49056f391444aba76306adfd48cd77a859274d5cbd2a8c23a00af78d
+EBUILD python3-saml-1.9.0.ebuild 737 BLAKE2B dfe2a322187209c39ded3053130418f2ee03830239c33aa82838e755caa1318881b8ba93071921284380761e672f38a54390a7652c8b6ba06f112a13189be5a7 SHA512 a62859afaaa19b10c09f045e47655deb57ab7ecd11fc0fc39770893bf0b78df9019cc41fea4d85e6afae92bb12544e58cb7b492c45dba82014ed3bae2c73d291
+MISC metadata.xml 255 BLAKE2B 2bb3830b8cec850703f7912f4c22f5b0abeabeed0715222bc56141779d02160773cfd0f85417c553c1cd8f2738bfeb78c56dffb8e648e572019319657646d1ba SHA512 522158915afe67937f81ba572a918a2de8ca1f8591e097da56799c97870d7c44756c1acd8224d63bd3375c2b9ebc0e1ce50816899117948a48065a27804883bf
diff --git a/dev-python/python3-saml/metadata.xml b/dev-python/python3-saml/metadata.xml
new file mode 100644
index 000000000000..56cae167d372
--- /dev/null
+++ b/dev-python/python3-saml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python3-saml/python3-saml-1.9.0.ebuild b/dev-python/python3-saml/python3-saml-1.9.0.ebuild
new file mode 100644
index 000000000000..dfaa71d04c5a
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+ https://pypi.org/project/python3-saml/"
+SRC_URI="https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/python-xmlsec[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+distutils_enable_tests setup.py