summaryrefslogtreecommitdiff
path: root/dev-python/python3-lxc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /dev-python/python3-lxc
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'dev-python/python3-lxc')
-rw-r--r--dev-python/python3-lxc/Manifest3
-rw-r--r--dev-python/python3-lxc/metadata.xml15
-rw-r--r--dev-python/python3-lxc/python3-lxc-3.0.1.ebuild22
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python3-lxc/Manifest b/dev-python/python3-lxc/Manifest
new file mode 100644
index 000000000000..c5f89494647a
--- /dev/null
+++ b/dev-python/python3-lxc/Manifest
@@ -0,0 +1,3 @@
+DIST python3-lxc-3.0.1.tar.gz 27424 BLAKE2B ffdf128e06d7b256652588af7c464045479ce907d2119dfe9780737c7bd5f3008c01d834a79f63932bfa51e3094a9d40af46c4cb6c3be72108205d65a8ee3d11 SHA512 7e6b6cb9a02e5af8b3fc8aeefff2954c68d2d1154751fa97a70bce86131021571e15db86bb0d6900a93dda78247e37b75cdfe250bf4d1b7548dc8383ed3d45f6
+EBUILD python3-lxc-3.0.1.ebuild 491 BLAKE2B 8c1bb3426469cb9ac16b93711cfc7fd2cf968e98445a7b802c21787b86274a8477eb6dbe7fd715c9cc2b22162d9023d6a7aad7fd54ddef206cf303a528d26d80 SHA512 a649decb8e7e0ba5e38d8385fcecd92cf150879ef8dc74c89611538f9581b151e9c6b4c5fd46e2f37a4d91dad0599fd2318d5a3a388e9242a8c66bb283dd601a
+MISC metadata.xml 475 BLAKE2B 4542a3c6240d1afce6fc554a255ed7097ab9923879241e73a77e391be5ee7f6638aaeb5f28ee859735c8abe412c3e62726aa64d67ce744ee1805bb7375dc1d87 SHA512 9db5e045665924cdcd5aa9d843be61c602440d2a18328db38733091ed0050e3c21f14c280a49c1db1bdcf9ae095b7bc58e50b5f3690e092502da87b2b5fc984a
diff --git a/dev-python/python3-lxc/metadata.xml b/dev-python/python3-lxc/metadata.xml
new file mode 100644
index 000000000000..168b59d5f4a5
--- /dev/null
+++ b/dev-python/python3-lxc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vdupras@gentoo.org</email>
+ <name>Virgil Dupras</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxc/python3-lxc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python3-lxc/python3-lxc-3.0.1.ebuild b/dev-python/python3-lxc/python3-lxc-3.0.1.ebuild
new file mode 100644
index 000000000000..d448c380fbc9
--- /dev/null
+++ b/dev-python/python3-lxc/python3-lxc-3.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxc/"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-emulation/lxc-3.0"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"