summaryrefslogtreecommitdiff
path: root/dev-python/python3-lxc/python3-lxc-3.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/python3-lxc/python3-lxc-3.0.4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/python3-lxc/python3-lxc-3.0.4.ebuild')
-rw-r--r--dev-python/python3-lxc/python3-lxc-3.0.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python3-lxc/python3-lxc-3.0.4.ebuild b/dev-python/python3-lxc/python3-lxc-3.0.4.ebuild
new file mode 100644
index 000000000000..ed6410dec9bb
--- /dev/null
+++ b/dev-python/python3-lxc/python3-lxc-3.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 verify-sig
+
+DESCRIPTION="Python bindings for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxc/"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
+IUSE="verify-sig"
+
+RDEPEND="app-emulation/lxc"
+BDEPEND="verify-sig? ( app-crypt/openpgp-keys-linuxcontainers )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc