summaryrefslogtreecommitdiff
path: root/dev-python/python-zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
commitd93ba9788a6ad1e5da2bf47e804456ded6d5c65c (patch)
treee01c10bcfe477cecf1770c8a8186e4a5344057b9 /dev-python/python-zeroconf
parent7bf32644d8b70a318475609992d8e4853ec4ec0e (diff)
gentoo auto-resync : 18:12:2022 - 09:41:22
Diffstat (limited to 'dev-python/python-zeroconf')
-rw-r--r--dev-python/python-zeroconf/Manifest4
-rw-r--r--dev-python/python-zeroconf/metadata.xml2
-rw-r--r--dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild59
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-python/python-zeroconf/Manifest b/dev-python/python-zeroconf/Manifest
index 0ad28317cf7d..73395c6b0369 100644
--- a/dev-python/python-zeroconf/Manifest
+++ b/dev-python/python-zeroconf/Manifest
@@ -1,3 +1,5 @@
DIST python-zeroconf-0.39.4.gh.tar.gz 137174 BLAKE2B 9e7d66bec5ebb52754c5a45fd584229db2f20f37cc43830b31c903a6267aadc3a45a3f8c35fd329586aa81f083dc823f0e6d6fad3dc2b6cc5ada17a2eb4a2208 SHA512 0e69a31dd31111f95eda0a44ee7d00484d8b909448eef4ef41bef6e170a410ecdae02e01cc944ad7534634aa26ef0c95b465c784ee67de1c2cd0ec4ab040d445
+DIST python-zeroconf-0.44.0.gh.tar.gz 149523 BLAKE2B 544187ad7baff6ea7a13b3ee3a51e6c19d872f006df3727900cad588febab0b86218c31c689203d3b674eed8ca67f0c9b39f83efec255696fa8405a00551edc8 SHA512 4190ca1d892dcbe5e5020c15a18cf1db80e7623798b64ba45b18dbfb5dd624e7851026f99aec14547b037927c06b7d9186e44cb4790e47613cb16c0cde3c067d
EBUILD python-zeroconf-0.39.4.ebuild 1364 BLAKE2B a14f806f42e6b62debc6cd32df0202bd904438e8a1d082e2aea43f761e36feace947b272ad22abba640f926c980db093ce20287fbffa62a26b210f107f3191d6 SHA512 5d39afd5d0aa32e424d4c6f63e2ef45585482f80b834410121eee48d23a493af43df2ff46142786d8912804cd2dd88cfd216a71c06ca42cf203eb8ec0c072524
-MISC metadata.xml 413 BLAKE2B f93eceda07029400d2fd7ab38f234e5a1747e3d86f228adc973bbd6cdc71456778a7d926457f976cb2c6f55678b2c671d2415e5c7a480306582f1e70f6f733dc SHA512 d228e198b2f495dd02cd3d9d948aae123461c70c8e0185a47b133000f0316a84ff33d9b6f4cc0196bca5cf638e53ae58a3cd746338c33729d957a1170a5f08dd
+EBUILD python-zeroconf-0.44.0.ebuild 1665 BLAKE2B 435d08aa7b5ee7b059055f5e9c1a96338717f1231ab9a21f449628f5dcaef5b06e779c37c183ddff0741cba1ce0e9490cf4acac3a82113bc8f626ff85a033772 SHA512 e57fe0013b4855ef2a6293dc2332a02f9d85e5762445653903a5cd7d2a17401bfd59ad884687250361b113e746a78fbc3ba1437384a2a0a90a022bd966668273
+MISC metadata.xml 420 BLAKE2B 68b48bf57199bc6bce47b1063d666e5d2a7a4c59e187bfe2d0384d53e7cb9b34831b6314a1befabfe644c5c64144f3230807608426cefc3a27ae70ebfa2089c6 SHA512 f5eac64063b3e2be0359bea3e7a61576381db31f3807e2ad7487cbbd8f443fea65c2f590a1049bbec7cb9051d179d72885d905f2e6f0b455a2aa195390b8f2b5
diff --git a/dev-python/python-zeroconf/metadata.xml b/dev-python/python-zeroconf/metadata.xml
index c1970e1e2792..8b419fd2477f 100644
--- a/dev-python/python-zeroconf/metadata.xml
+++ b/dev-python/python-zeroconf/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">zeroconf</remote-id>
- <remote-id type="github">jstasiak/python-zeroconf</remote-id>
+ <remote-id type="github">python-zeroconf/python-zeroconf</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild b/dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild
new file mode 100644
index 000000000000..071363ef01ef
--- /dev/null
+++ b/dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/python-zeroconf/python-zeroconf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}