summaryrefslogtreecommitdiff
path: root/dev-python/python-zaqarclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-zaqarclient
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-zaqarclient')
-rw-r--r--dev-python/python-zaqarclient/Manifest4
-rw-r--r--dev-python/python-zaqarclient/metadata.xml19
-rw-r--r--dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild39
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/python-zaqarclient/Manifest b/dev-python/python-zaqarclient/Manifest
new file mode 100644
index 000000000000..261723460568
--- /dev/null
+++ b/dev-python/python-zaqarclient/Manifest
@@ -0,0 +1,4 @@
+DIST python-zaqarclient-1.2.0.tar.gz 66649 SHA256 afe1a0a32b9595feb8dd15c8f5affd23e80c4c4ecd73fef3a7d17076cb9cf39b SHA512 1590839460815daa1f0754d47ef789e0c2d2a078265bbb6595eac32114a36c5f15512a2781841955fe99cbdf2cdaa8a13061f535229a284f5b98f97d017dd8a2 WHIRLPOOL 5b47eabb2aba03e1a9168946e9b0018b3ca6e3099a5a34e2147a58786c5bef3c47fc97a8360a042d58c13e30e4cd4fda0d13d2f95d1481364e46719fa11ed40d
+EBUILD python-zaqarclient-1.2.0.ebuild 1240 SHA256 3fa88bfedf9fa3afc211a1faa5557c2246515c4b6c37e879cae39a0f98318a65 SHA512 3a62c878c06efb3748d77a31371f5f5c59a6c51c8580359f8f75efeb835feb517a0be8bfa08387508cbec3c212bd53108dcb4ef8b4e5ceb3f191751b8a237a79 WHIRLPOOL c1891ae0cc9923ab450c748b132b5f56eb9f1cc6e9e739bfc0533b314ce6f79a0842f9ea9ead456226b76f03278a973fa0a28434daaa2fccd5030cbe19d04e0f
+MISC ChangeLog 507 SHA256 52d107cd09967e73de39096424c72020bd593abc365312f15abf0e6ead0573cb SHA512 06b2dd10beab7e5710381b5774b283a12b054ea2abe8b2c98fd53a33bcf9e0b3d405a8d69e4d19fccfa9dcbc56e635f08b573d34c874c1107bd4cc60c44f91d3 WHIRLPOOL 22a7b055c62734917600ac04bec96739a5ac29f98d0e4d0a4533f85691858a06daf7b567352b10bb115d9bd468dda58930cd43d1a281d26c20bbf72f2271630b
+MISC metadata.xml 610 SHA256 74b67ca27b333e69e88c6b8d50ff3ac29a7e41b2886de248814279466ea40afe SHA512 8aff588cc301541b529b0387623c4189830e0ddd837c5570343c7e23a9d49740ed06f6586ef63308e9a3c6968ec1aa785d84d7563a8e7899949d3352e9d75efe WHIRLPOOL 74e5ed92f3700a4364dea871a1b85bff400472bfea4cf8042fa8cbb57d1f4697bcba25c35507364defc4e9adecd321e3001bf7e7ea3b3ec20ef1c571ae4751fb
diff --git a/dev-python/python-zaqarclient/metadata.xml b/dev-python/python-zaqarclient/metadata.xml
new file mode 100644
index 000000000000..f538ac4d0baf
--- /dev/null
+++ b/dev-python/python-zaqarclient/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a client for the OpenStack Zaqar API.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-zaqarclient</remote-id>
+ <remote-id type="github">openstack/python-zaqarclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
new file mode 100644
index 000000000000..332eb2f93810
--- /dev/null
+++ b/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.0.2[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}