summaryrefslogtreecommitdiff
path: root/dev-python/python-xmp-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 16:01:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 16:01:10 +0000
commit724cccb689f2076a398ede6845749926c86ea647 (patch)
tree766c785a64ac7265adee059e793fc120be6c434f /dev-python/python-xmp-toolkit
parent73ef00f9e2b100c7d0fedede11300940cc26670a (diff)
gentoo auto-resync : 27:02:2023 - 16:01:10
Diffstat (limited to 'dev-python/python-xmp-toolkit')
-rw-r--r--dev-python/python-xmp-toolkit/Manifest2
-rw-r--r--dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch68
2 files changed, 65 insertions, 5 deletions
diff --git a/dev-python/python-xmp-toolkit/Manifest b/dev-python/python-xmp-toolkit/Manifest
index 6b2f179455b7..84b2085b1fb3 100644
--- a/dev-python/python-xmp-toolkit/Manifest
+++ b/dev-python/python-xmp-toolkit/Manifest
@@ -1,4 +1,4 @@
-AUX python-xmp-toolkit-2.0.1-test.patch 397 BLAKE2B 059d415194f4544de5e4f6bfcbc2bec466b14e72e46792ac762115dd8b33bcd87ebfcdc9412695bd5b75483ac6e82024c083725ed73713c1bad100c30f22448a SHA512 f70eb11fe5b46ec0fac9a4a5c56a7a5b9dc75427b53e8159ec873a74afde23ca4bf5940b185932fc566a10f8a47d2ff8e56fa514eac1b06c94135cfa7070747b
+AUX python-xmp-toolkit-2.0.1-test.patch 2953 BLAKE2B 84794d759a96cdd2d56f9b254a4564ab1d2a6e0453c8d3130ae2f461db487875d5bc6f6989b2423f36b6cae38e578cf3afc5d1f1576534e33abdcf846c0de6f2 SHA512 903caa29a67b9332cee721882e28da7cb3f565ad97d0c75b6a1b14e8e62156a6afea370843cd2bf700d4703a1fed94a3eaa932a0ee493681190897ab80dbae6f
DIST python-xmp-toolkit-2.0.1.tar.gz 3576384 BLAKE2B cbe73d08d101d0d44c368fd1f1c6f1c8308ece5ca26f164f78312d901fb5d0387a5d2a6519d527b3625d11e338df5c366bed8a7361ac822ac887ef8be3a74948 SHA512 46f83b03574b2d742f6c6efb5b94a549068557ad6338e74fc62368c265d05f0b66a4dd36b17cd51b39f7b6cfbfb1210d54cc44c69e9a9e3da3392ee5f11de3bd
EBUILD python-xmp-toolkit-2.0.1-r2.ebuild 889 BLAKE2B 8f5651b4affbf5c1b6437763e9d23562d41d95b5285acb2a989dc9a754843a3d9ce878028d08c24479b8e914075d8f89b02bbaebb5a49367da43f94d62ab8513 SHA512 641e88b585dc4a1dc19ba0cbe2b906d7038afa947b0fabe1aa09fea9cfa2cefd0cb9680c8037dd08b16190eb7cd8fe79e2e0a82033f9b45a6f9d3899e92d2832
MISC metadata.xml 417 BLAKE2B 818d54b619c9571b00493c9c463f4e2899c187071918f9e74189d8be23b97f4cd9a8ca0313c5f26507f9e581d8e268be3fe17f03c3f409b1eb333540fb48d380 SHA512 dc5ef8f44af10a54da69fc6bbd392c4da30ecc49c829f2f8c26022e2d42da3ab0a705f31bd72f404454fe76daf1162ecb72ea1e106c93a48cdf100b59f492a91
diff --git a/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch b/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch
index 7679542cf535..e2adc3c05403 100644
--- a/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch
+++ b/dev-python/python-xmp-toolkit/files/python-xmp-toolkit-2.0.1-test.patch
@@ -1,7 +1,67 @@
-diff -r -U1 python-xmp-toolkit-2.0.1.orig/test/test_exempi.py python-xmp-toolkit-2.0.1/test/test_exempi.py
---- python-xmp-toolkit-2.0.1.orig/test/test_exempi.py 2014-03-09 19:42:07.000000000 +0700
-+++ python-xmp-toolkit-2.0.1/test/test_exempi.py 2020-01-21 18:16:13.470778818 +0700
-@@ -539,2 +539,3 @@
+Squashed patches of the following:
+
+- https://github.com/exmakhina/python-xmp-toolkit/commit/3f7546173980610e0687f4eae4eb28aa026e4674
+ gentoo commit 14321e655b7b3f6e531c0a079cb131dbd767e1be
+
+- https://github.com/exmakhina/python-xmp-toolkit/commit/1459510907764746534ce41afa85a3bedd7029b9
+ test: disable tests involving BlueSquare.gif
+
+- https://github.com/exmakhina/python-xmp-toolkit/commit/bd8a0babef830e9a2c06150f6277ba0ddb1220bd
+ libxmp: exempi: exempi returns char-sized bool, not int
+
+diff --git a/libxmp/exempi.py b/libxmp/exempi.py
+index 683e240..cddc038 100644
+--- a/libxmp/exempi.py
++++ b/libxmp/exempi.py
+@@ -1693,6 +1693,7 @@ def check_error(success):
+ Return value from library function indicating success or failure.
+ """
+
++ success = success & 0xff
+ # Unfortunately the success parameter does not seem to always be reliable
+ # so we supplement it by explicitly checking the error code.
+ ecode = EXEMPI.xmp_get_error()
+diff --git a/test/common_fixtures.py b/test/common_fixtures.py
+index 135a795..363246c 100644
+--- a/test/common_fixtures.py
++++ b/test/common_fixtures.py
+@@ -44,7 +44,6 @@ samplefiles = {
+ 'BlueSquare.ai' : libxmp.consts.XMP_FT_ILLUSTRATOR,
+ 'BlueSquare.avi' : libxmp.consts.XMP_FT_AVI,
+ 'BlueSquare.eps' : libxmp.consts.XMP_FT_EPS,
+- 'BlueSquare.gif' : libxmp.consts.XMP_FT_GIF,
+ 'BlueSquare.indd' : libxmp.consts.XMP_FT_INDESIGN,
+ 'BlueSquare.jpg' : libxmp.consts.XMP_FT_JPEG,
+ 'BlueSquare.mov' : libxmp.consts.XMP_FT_MOV,
+diff --git a/test/samples.py b/test/samples.py
+index 4a97203..a7e0412 100644
+--- a/test/samples.py
++++ b/test/samples.py
+@@ -65,7 +65,6 @@ samplefiles = {
+ 'BlueSquare.ai' : libxmp.consts.XMP_FT_ILLUSTRATOR,
+ 'BlueSquare.avi' : libxmp.consts.XMP_FT_AVI,
+ 'BlueSquare.eps' : libxmp.consts.XMP_FT_EPS,
+- 'BlueSquare.gif' : libxmp.consts.XMP_FT_GIF,
+ 'BlueSquare.indd' : libxmp.consts.XMP_FT_INDESIGN,
+ 'BlueSquare.jpg' : libxmp.consts.XMP_FT_JPEG,
+ 'BlueSquare.mov' : libxmp.consts.XMP_FT_MOV,
+diff --git a/test/test_exempi.py b/test/test_exempi.py
+index 690ce15..54065e2 100644
+--- a/test/test_exempi.py
++++ b/test/test_exempi.py
+@@ -422,7 +422,6 @@ class TestExempi(unittest.TestCase):
+ """Verify that check_file_format function works as expected."""
+ pairs = { 'avi': libxmp.consts.XMP_FT_AVI,
+ 'eps': libxmp.consts.XMP_FT_EPS,
+- 'gif': libxmp.consts.XMP_FT_GIF,
+ 'indd': libxmp.consts.XMP_FT_INDESIGN,
+ 'jpg': libxmp.consts.XMP_FT_JPEG,
+ 'mov': libxmp.consts.XMP_FT_MOV,
+@@ -540,6 +539,7 @@ class TestIteration(unittest.TestCase):
+ self.assertEqual(props, ["2006, Hubert Figuiere"])
+
+ @unittest.skip("Issue x1")
def test_single_namespace_single_path_leaf_names(self):
+ """Get just leaf names from a single path, single namespace."""
+ # TODO: why?