summaryrefslogtreecommitdiff
path: root/dev-python/python-xcaplib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-xcaplib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-xcaplib')
-rw-r--r--dev-python/python-xcaplib/Manifest3
-rw-r--r--dev-python/python-xcaplib/metadata.xml21
-rw-r--r--dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild24
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-xcaplib/Manifest b/dev-python/python-xcaplib/Manifest
new file mode 100644
index 000000000000..af140b2eeb87
--- /dev/null
+++ b/dev-python/python-xcaplib/Manifest
@@ -0,0 +1,3 @@
+DIST python-xcaplib-1.1.0.tar.gz 22892 BLAKE2B 61600032e906996da96cd5c4b2c24b11988c0482242d9b20d5c000a63bee704968bd1ec3f61955b9246581df04fdfa6dec8fc34ebef8c573c5fc5e82b74a43a3 SHA512 140a12e39decdd15c06816cf5969baaf82437f010592ee2f4b7309db585aaa6611ab3af50e399bb18d216ae1586b5ebf18490d74c385a99d6673171bcf437395
+EBUILD python-xcaplib-1.1.0.ebuild 550 BLAKE2B 820b113dcf92957a22d483ea2564d1e0d3e71b2b69f107d4fb949163b88344dad7fa9dbc605d61e846d29ec80b8c071da571b06288290ccbf335f22569967178 SHA512 146b060138860ed504179f1d96c808a54c1cfb2e5d8b27f83df683353b50e200892f73471bc6bddbfc9bd4d8161ca0bd281c428cb96fb126fee3516defa87055
+MISC metadata.xml 898 BLAKE2B 79eee5dee0299412f44302465f01dd6cd9e6d539eeda1c90fc3a650227419249bd9a13149679124b3383d932aa6c90f6fb5fbcf79a13cab38bc9e90c9898f28c SHA512 6da7eaed0415c31d9ca6591e62a0308ef8f8e7f5849131ee7c4ad26a04f7f8f751784d71e880db304928597be1f0e1352c0e328d3464c147cfe37f1550a3cedf
diff --git a/dev-python/python-xcaplib/metadata.xml b/dev-python/python-xcaplib/metadata.xml
new file mode 100644
index 000000000000..e28a9e7635cb
--- /dev/null
+++ b/dev-python/python-xcaplib/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ XCAP protocol, defined in RFC 4825, allows a client to read, write,
+ and modify application configuration data stored in XML format on a
+ server. XCAP maps XML document sub-trees and element attributes to
+ HTTP URIs, so that these components can be directly accessed by HTTP.
+ An XCAP server used by XCAP clients to store data like presence
+ policy in combination with a SIP Presence server that supports
+ PUBLISH/SUBSCRIBE/NOTIFY SIP methods can provide a complete SIP
+ SIMPLE solution.
+
+ The XCAP client example script provided by this package can be used to
+ manage documents on an XCAP server.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
new file mode 100644
index 000000000000..4283bacd35f0
--- /dev/null
+++ b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_REQ_USE="ssl,xml"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for managing XML documents on XCAP server"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/XCAP/python-xcaplib-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-application[${PYTHON_USEDEP}]
+"