summaryrefslogtreecommitdiff
path: root/dev-python/python-varlink/python-varlink-31.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
commit9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (patch)
treeb70c1d27324b2ed33e5688d4a21f6c5195032ecf /dev-python/python-varlink/python-varlink-31.0.0.ebuild
parent1cf3f23200484257eaf7d863e323e7e9aee98d2b (diff)
gentoo auto-resync : 24:12:2022 - 14:02:21
Diffstat (limited to 'dev-python/python-varlink/python-varlink-31.0.0.ebuild')
-rw-r--r--dev-python/python-varlink/python-varlink-31.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-varlink/python-varlink-31.0.0.ebuild b/dev-python/python-varlink/python-varlink-31.0.0.ebuild
new file mode 100644
index 000000000000..9d6572de9555
--- /dev/null
+++ b/dev-python/python-varlink/python-varlink-31.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Varlink protocol"
+HOMEPAGE="
+ https://github.com/varlink/python/
+ https://pypi.org/project/varlink/
+"
+SRC_URI="
+ https://github.com/varlink/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}