summaryrefslogtreecommitdiff
path: root/dev-python/python-varlink/python-varlink-30.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /dev-python/python-varlink/python-varlink-30.3.0.ebuild
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'dev-python/python-varlink/python-varlink-30.3.0.ebuild')
-rw-r--r--dev-python/python-varlink/python-varlink-30.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-varlink/python-varlink-30.3.0.ebuild b/dev-python/python-varlink/python-varlink-30.3.0.ebuild
new file mode 100644
index 000000000000..ebf96d3a69e4
--- /dev/null
+++ b/dev-python/python-varlink/python-varlink-30.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Varlink protocol"
+HOMEPAGE="https://github.com/varlink/python"
+SRC_URI="https://github.com/varlink/python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+RESTRICT="test"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/python-${PV}"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}