summaryrefslogtreecommitdiff
path: root/dev-python/python-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/python-utils
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest4
-rw-r--r--dev-python/python-utils/python-utils-3.5.1.ebuild38
-rw-r--r--dev-python/python-utils/python-utils-3.5.2.ebuild38
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 5b321cbfcc01..96b5742dd431 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,3 +1,7 @@
DIST python-utils-3.4.5.tar.gz 28608 BLAKE2B c933bf358ad61563fc35bc87329367946a64216afaddb3cd5bff861e0e1fadcc4d18c7a8ff7820bfee5938bc7ede3cea9d450ecc5b7c0825f917c59576d7195c SHA512 35b4b49dfce56e9e530fe979c070889296079d3a1fd548186bf6dbd6fdbce5363818b52a5d7559b7af3bd32561d87639565298386883351168a267fa88e1ff7f
+DIST python-utils-3.5.1.tar.gz 26753 BLAKE2B f6a6f84883671e4e17938bf8a70332766b3e61f77bd86eda976915a5967710c4c8a6bdd295b6ca9d46bed98b30866bbaabd67ac3d4311dfe061fbc3c5a41e4af SHA512 427660db279b438ce30218bea72f96b952f6cd37c99184f04d458814500f056b16ed4f2fa743f94499a996366c162006c771e9523491afb2a7ee0f666ab98718
+DIST python-utils-3.5.2.tar.gz 26883 BLAKE2B 9532d8fecd8d57a9a9f50e2e7e67386e4c5922f4ec316851544147f6da82586bb01796bb3e3fc95c894a790c57711c983d8da9abc5edc5a722089a0d86d7fb61 SHA512 2e36bbb2e43591744c63ea972b7f361138694eb32510643ea88e8d757882379e3aec247c2fc4d5c67876939b71d564570a975700728c79f9db0cc4fcbc1605e7
EBUILD python-utils-3.4.5.ebuild 762 BLAKE2B 506433911e055bfd82cf4832c9938ea9867c5bcc0558365a51842958aef0083a644fed621679f573d5882fc030139895eeddc3df32b44a9a8520df2bbd1929fc SHA512 4a4326178f7d948a37726cee5684086d3de847678025e6c8771f6075c4cdbfab90d7050c5bade86d4688f127fb2d653b0b629bf464c56989c050d928b3709e6e
+EBUILD python-utils-3.5.1.ebuild 716 BLAKE2B e95ef0cb070a22b917f6dab2099647277ef226dcb8926e0148031dcb7ef2ffe295332c7b2b9c762df69f033f648c3f03e13fa97a1549cf63e263ca96720730b8 SHA512 8401640356674a4ab6d598523d5c04cdc53cc7b16d687320dac8eb87dc515608b5001089b7299205c759c95a448fc4ef3eda4d92abc73fb5eb4e728c3ac08587
+EBUILD python-utils-3.5.2.ebuild 716 BLAKE2B e95ef0cb070a22b917f6dab2099647277ef226dcb8926e0148031dcb7ef2ffe295332c7b2b9c762df69f033f648c3f03e13fa97a1549cf63e263ca96720730b8 SHA512 8401640356674a4ab6d598523d5c04cdc53cc7b16d687320dac8eb87dc515608b5001089b7299205c759c95a448fc4ef3eda4d92abc73fb5eb4e728c3ac08587
MISC metadata.xml 340 BLAKE2B dc9b0299a4b93a0e53cc8e8e5ab494a8bf04ea54da4c2f9a658ca485925f86b5a765299c6680ecbff1e29a4e94a88dcac1891e440c788ada76b2123e352ac6f2 SHA512 68222ff7625c88a73f918e1864b67a2a44ef128023668b2a8706e873b4a8703928f1961baa0b304fe8fa075261edcd183bae02a2416813b283aa57c16bf6e200
diff --git a/dev-python/python-utils/python-utils-3.5.1.ebuild b/dev-python/python-utils/python-utils-3.5.1.ebuild
new file mode 100644
index 000000000000..2f51e06e8c85
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/python-utils/python-utils-3.5.2.ebuild b/dev-python/python-utils/python-utils-3.5.2.ebuild
new file mode 100644
index 000000000000..2f51e06e8c85
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}