summaryrefslogtreecommitdiff
path: root/dev-python/python-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/python-utils
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest4
-rw-r--r--dev-python/python-utils/python-utils-2.6.0.ebuild24
-rw-r--r--dev-python/python-utils/python-utils-2.6.3.ebuild24
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 9ec8442edf2b..7a6f7e97533d 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,3 +1,7 @@
DIST python-utils-2.5.6.tar.gz 14057 BLAKE2B 2f66ab26cd6cda25f73c9f40081048404cde819e3e3c2fd11d134244ab2b80a05ab2b943e56a45bd8656bf3ba231853e3bfa9efbab9cb70515daaec70f6e0715 SHA512 35299880afdecd4a44144b95e6b2073e51680dfd2b00f31fb333d578cfa2c2f8bf5f58128cab88a7b81e658e6d5dca303f1c9f5be3870160679e1defbf94859e
+DIST python-utils-2.6.0.tar.gz 14885 BLAKE2B 089d7a57a8469968bed147a01907f35d1430349130e0f7152bbd38dd65053cf3d6424942eee8cc9006baaec5f13bffcbef81bd8723cad7ee03b1358a5c2d3d27 SHA512 a582558e38342f54f7c1eda1f9038728dd5904729aaec4e5719e56bb447bc6fcb93bf5ea3af134ce245eda059b9be81d15b268165cbc10799ba112fc157f939b
+DIST python-utils-2.6.3.tar.gz 14914 BLAKE2B 6df19348feba000dccc516704db38af299613c70505cd7fa16a2e37c4a46b1cff7ee9bf164be13da33a3b4eb6b9577b76202bfbffdaed47b1b7b60e948d349ac SHA512 3c5834976408eae6b37aa07581960ee5511765f9ea1e6347523465a93ca801bc2d71f785a73a2050706dad2c09ffcfb5227715a9b4d0700904d31eb1295b30b6
EBUILD python-utils-2.5.6.ebuild 574 BLAKE2B 49716b98a6d7a997149be3fb8b0daf5386c5ab180b9eb7c022fff18c73101314807f498f332db2a6b555bdbe67be68bddcf48ac28860727baa10f2c54cd1ea6a SHA512 6a91b1a761fe2f60d6810d6cd3b676dfb87a34982be3284a7d74fda7794874f358fcd4e97b89189e0db4839d6b0f126889abca8c0b6b926fc0db33c3849d3201
+EBUILD python-utils-2.6.0.ebuild 575 BLAKE2B ffb8a2711fb4f8fc1f96ce30f2425619d0849af1d42ec8bcaa97d9c7f0a737d475255f76cceb8e93a55e5bccde4988b0e4ecd7bc1deb2b65b7b230595088b3e4 SHA512 85e20c3c8cd71d72039a1c0c83bcf10aa390c712b47c219dfa67c2de00bb68b0700f9a0a3ab140955d0ae320c6d7160946640d7f4202a28ba09ae342af7a5d78
+EBUILD python-utils-2.6.3.ebuild 575 BLAKE2B 5791d01204f77da103781b305bbf1e4b88e5377fca285b03835886b9f26f04900ca436a11b4653a9d240d934b160a3268b4e3ebaa7b58b59e6b219c31dab55ec SHA512 a1cad83a0ba5ccabad120e4a65c9712bb1824b7ff8db6b9a64222bce4e4e141a6af94214ae2791109c875a078caaea494ed6d33fce6c2fd81e8bdc9b0ca28e00
MISC metadata.xml 340 BLAKE2B dc9b0299a4b93a0e53cc8e8e5ab494a8bf04ea54da4c2f9a658ca485925f86b5a765299c6680ecbff1e29a4e94a88dcac1891e440c788ada76b2123e352ac6f2 SHA512 68222ff7625c88a73f918e1864b67a2a44ef128023668b2a8706e873b4a8703928f1961baa0b304fe8fa075261edcd183bae02a2416813b283aa57c16bf6e200
diff --git a/dev-python/python-utils/python-utils-2.6.0.ebuild b/dev-python/python-utils/python-utils-2.6.0.ebuild
new file mode 100644
index 000000000000..ae6983ffe562
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/python-utils/python-utils-2.6.3.ebuild b/dev-python/python-utils/python-utils-2.6.3.ebuild
new file mode 100644
index 000000000000..007ee75b0b0a
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.6.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}