summaryrefslogtreecommitdiff
path: root/dev-python/python-uinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-uinput
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-uinput')
-rw-r--r--dev-python/python-uinput/Manifest3
-rw-r--r--dev-python/python-uinput/metadata.xml11
-rw-r--r--dev-python/python-uinput/python-uinput-0.10.2.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-uinput/Manifest b/dev-python/python-uinput/Manifest
new file mode 100644
index 000000000000..853d6cceafa8
--- /dev/null
+++ b/dev-python/python-uinput/Manifest
@@ -0,0 +1,3 @@
+DIST python-uinput-0.10.2.tar.gz 21736 BLAKE2B 789d0b2065fc61f734b1f8ac12a6bce68c9776231c13a73a79d535092cc65229b27f3f84b5bc28a6bf4bd48adfc00cc5c7ec92c0ebf2ae827b89e0fc26ec2bf6 SHA512 0009e3c3f82c5a5da61e9adf17d77a2efb9223f02324a4f7c7033b165d5e4e395566c34ccb11ef54cc4ce1623b1432a144614cbae7a88e9c06824b15ef00e1b7
+EBUILD python-uinput-0.10.2.ebuild 525 BLAKE2B 7b4bc7c5291fb687ed75429551b1585261568aafe76f1776a9afde6f7da186c03608e1f50c34746d5781aa5bfca2e29949bc363118714e6ffaa91c3ea4039408 SHA512 f454fa99b1a19c3c9e424cb4b5284c81087ddf5cd9e9515162dba71e38a5d955a10964554ccce85eccc95fd6663b0b122fc65b323430f0baf2d41289490985bd
+MISC metadata.xml 326 BLAKE2B 583f25e22df551db892a18d60ba04753b37c6a188e6bb338a118c02d72b07c37e938504002aafee2d9b3d71d4845ffe2124f94fb2143234b2fb3c400e0f6893d SHA512 f6fbc6b93ca26169abdcbe1ec78a7e216a90ab9aeee1f0195123e4afb74590216ad4179fe22503ee2b0999cdd394287b5908c094453b79b4d1bef3ccc20a8a12
diff --git a/dev-python/python-uinput/metadata.xml b/dev-python/python-uinput/metadata.xml
new file mode 100644
index 000000000000..a10aca152207
--- /dev/null
+++ b/dev-python/python-uinput/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-uinput</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-uinput/python-uinput-0.10.2.ebuild b/dev-python/python-uinput/python-uinput-0.10.2.ebuild
new file mode 100644
index 000000000000..81d147a11552
--- /dev/null
+++ b/dev-python/python-uinput/python-uinput-0.10.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic API to the Linux uinput kernel module"
+HOMEPAGE="http://tjjr.fi/sw/python-uinput/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/udev"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ rm libsuinput/src/libudev.h || die
+ distutils-r1_python_prepare_all
+}