summaryrefslogtreecommitdiff
path: root/dev-python/python-tvrage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-tvrage
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-tvrage')
-rw-r--r--dev-python/python-tvrage/Manifest3
-rw-r--r--dev-python/python-tvrage/metadata.xml12
-rw-r--r--dev-python/python-tvrage/python-tvrage-0.4.1.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-tvrage/Manifest b/dev-python/python-tvrage/Manifest
new file mode 100644
index 000000000000..8b1a92d29d88
--- /dev/null
+++ b/dev-python/python-tvrage/Manifest
@@ -0,0 +1,3 @@
+DIST python-tvrage-0.4.1.tar.gz 10646 BLAKE2B a2d48fd8042fb7d59ca5401eb200e4936e1764e84404c2db20131cc5b7b8c144bb9c3d06a08662954360e78a3177b193a8128b69a115b2e7c91af2561b4ef262 SHA512 cabee676e85206b8c052b79b0f5fd039719ede104607795fe8d1947f2fd810fd9fd08ba8c6e94d1fa68dd5e51060e10fb9c12349f21b752242f7eae2b4771009
+EBUILD python-tvrage-0.4.1.ebuild 574 BLAKE2B e651a77894d3ff558e87acef02d4716f914cdc27ebdb17a15b4216da09922fc5be99c5a5948e7d2464b964aaf851aa6b57d6f0020803889a9170184b7b8f5311 SHA512 2acd183d6eaccf92caa0486219a6f075ea29b1512d9cd5fe7f90d6b5ceb270f1d6212c12bf38eb6389c7a2418bdaf634900439245275e725c942b2c9d31e48d8
+MISC metadata.xml 391 BLAKE2B 35dc04efa7f2405a58e1aeba8f4cfb11da9e5b51e524644424aae4325343fbec02b5a7e32c646663dedf3fb16b5a068b41e2421e2be40f86b2cc51a1b3b87c93 SHA512 1cae776c246c2337ef4f117db05bc36b5ec362be64a43e1ba1046c0d94d8da7962d58ba5c72ae376774376638cd1fef1a18eba2fdb77b298ef4c64622f605e33
diff --git a/dev-python/python-tvrage/metadata.xml b/dev-python/python-tvrage/metadata.xml
new file mode 100644
index 000000000000..9f173cf4616f
--- /dev/null
+++ b/dev-python/python-tvrage/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-tvrage</remote-id>
+ <remote-id type="github">ckreutzer/python-tvrage</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild b/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild
new file mode 100644
index 000000000000..90e3d7bb6bea
--- /dev/null
+++ b/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for the tvrage.com XML API"
+HOMEPAGE="https://github.com/ckreutzer/python-tvrage"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" tests/api_tests.py || die "Testing failed with ${EPYTHON}"
+}