summaryrefslogtreecommitdiff
path: root/dev-python/python-tests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
commitbb59556b3302a941db4630613c604644d5f7a617 (patch)
tree42e60b7ae227b0fe3af52dfac08d59653066a2db /dev-python/python-tests
parent3cd09a18bad26aad2645241b868755cfdf41b6ae (diff)
gentoo auto-resync : 11:04:2025 - 08:43:58HEADmaster
Diffstat (limited to 'dev-python/python-tests')
-rw-r--r--dev-python/python-tests/Manifest1
-rw-r--r--dev-python/python-tests/python-tests-3.13.3-r100.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/python-tests/Manifest b/dev-python/python-tests/Manifest
index ed3e211c044a..267dd83266e8 100644
--- a/dev-python/python-tests/Manifest
+++ b/dev-python/python-tests/Manifest
@@ -30,5 +30,6 @@ EBUILD python-tests-3.12.10.ebuild 1509 BLAKE2B c6e4425233b8489047328797e0597aeb
EBUILD python-tests-3.12.9.ebuild 1507 BLAKE2B ae599721e39a2bdf341692e124004eaf8dff821e55bf8d877578f5b304339bb0658825a1995e97c3b66b896f295d72c57cfc2954a0f4200dee22ce20f7f7d660 SHA512 2f0794c454535380fba5299065ce14fd41e99f602ecd002aec3588955b83fc92942e9547dfc462176d3b16dc743cbb9e01cb5171333f9011750c29e32ee8fe24
EBUILD python-tests-3.13.2-r100.ebuild 1478 BLAKE2B e4be6217ea6bc0018bd5378221397d025f6e12d1fb52f9f51551f7f6d746b84664ebffc4d830807c913564030fd9736a22990390be9177e59c71c503d31b88ca SHA512 6b65bcf69212be740f96b88e48ab076ea531e15789e324af63cd1d88daf64d0cc0795e84df1cb9f2c6119d8022eb438e6eb90e8aa932e1bc8da0616da72944c4
EBUILD python-tests-3.13.2.ebuild 1513 BLAKE2B 7754a584005b91e14843755d70f78d8a814937eb1cacec5f4f82227f9ec580de09913198c5fe3882813d444970da14ab73ba7d79e68a511ecc71a3dab9b096da SHA512 c619666601342dfe1721af12c8996d2952d3705576a72e2f96c3e205868378456b0c8cadd84f8acd23989246de618f43d8e61f25ecb025a21bcee2d91e966685
+EBUILD python-tests-3.13.3-r100.ebuild 1478 BLAKE2B e4be6217ea6bc0018bd5378221397d025f6e12d1fb52f9f51551f7f6d746b84664ebffc4d830807c913564030fd9736a22990390be9177e59c71c503d31b88ca SHA512 6b65bcf69212be740f96b88e48ab076ea531e15789e324af63cd1d88daf64d0cc0795e84df1cb9f2c6119d8022eb438e6eb90e8aa932e1bc8da0616da72944c4
EBUILD python-tests-3.13.3.ebuild 1515 BLAKE2B 2540fbec486e1347e1dc81a32cbd2095a28c8840a254fdbf31a6b814888f4a0623136e396badbf36939ea3f10d9e93147bc78bb7857152c964e5d948b45e9aa8 SHA512 017ac2bc391513afb335ef41b0ae3b6e6f9adb10197f52040e4e4442de053cc6b3cf922a00910f728d343f9d34e796b7eee75f6ba813be2b9693de1122b639a7
MISC metadata.xml 320 BLAKE2B 4a0e2e1a1885c485f99da97298accb9b35bf3bfa9b5e442ad0a92ed13e9e5b5d754bd10fff44e90862e7277aa11ebff8e41354cff1d63307258ed25ba9336d2f SHA512 5c78ec7965ba88dc488b4fa2a39f19f27e34c1ed770d03d13bb9f8b5b39257288957ede00ec85b46fff42f24e052960f0cfe94b48e2269465e0afe44adcdac99
diff --git a/dev-python/python-tests/python-tests-3.13.3-r100.ebuild b/dev-python/python-tests/python-tests-3.13.3-r100.ebuild
new file mode 100644
index 000000000000..2bbbf5a45614
--- /dev/null
+++ b/dev-python/python-tests/python-tests-3.13.3-r100.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_13t )
+
+inherit python-r1 verify-sig
+
+MY_PV=${PV/_}
+MY_P="Python-${MY_PV%_p*}"
+PYVER=$(ver_cut 1-2)t
+PATCHSET="python-gentoo-patches-${MY_PV}"
+
+DESCRIPTION="Test modules from dev-lang/python"
+HOMEPAGE="
+ https://www.python.org/
+ https://github.com/python/cpython/
+"
+SRC_URI="
+ https://www.python.org/ftp/python/${PV%%_*}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz
+ verify-sig? (
+ https://www.python.org/ftp/python/${PV%%_*}/${MY_P}.tar.xz.asc
+ )
+"
+S="${WORKDIR}/${MY_P}/Lib"
+
+LICENSE="PSF-2"
+SLOT="${PYVER}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~dev-lang/python-${PV}:${PYVER}
+"
+BDEPEND="
+ ${RDEPEND}
+ verify-sig? ( >=sec-keys/openpgp-keys-python-20221025 )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/python.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.xz{,.asc}
+ fi
+ default
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+
+ cd .. || die
+ default
+}
+
+src_install() {
+ python_setup
+ # keep in sync with TESTSUBDIRS in Makefile.pre.in
+ python_moduleinto "/usr/lib/python${PYVER}"
+ python_domodule test
+ python_moduleinto "/usr/lib/python${PYVER}/idlelib"
+ python_domodule idlelib/idle_test
+}