summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/python-swiftclient
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 56456a370ea4..a24e0fbee320 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,5 @@
DIST python-swiftclient-3.13.0.tar.gz 201575 BLAKE2B b098f3980590a562278417f572a762064fdc04c643a50767bab15f07679148854d373e0418f9996327fca6fca4ab53b4363b1d681706f96d0c25925bb84a6525 SHA512 b228337d1ecd3adc1bbb9f9ac5bd16cc068feadaf4faf398fd84c2a05ee226fa2dd5b4af639229b62271a4546f6db3e02bc0479288e0269745b1a9ff82e6c841
+DIST python-swiftclient-3.13.1.tar.gz 201632 BLAKE2B f7cdf7e30ea333f568c8ef06d065b18908b1e4c9f8f0b777906bdfa8f6c998292136859f62f0d2e58465ee9eec3452d29e3e69ed7567a07bfcddcf6ad1bf321c SHA512 bd958fb8cfde6f72bcf82d381ce06e0e94c383aee85abab5a111c408bacf2578eaf53244ae12438d4454fcefe8d867246aef952d1d15012364e20817cc90042d
EBUILD python-swiftclient-3.13.0.ebuild 921 BLAKE2B 8ebb668fd3a6259bbfbfa9d1db8ea789473eb241630b02c6812f542432e4d54b067cfe00cf1d5342df41bdacedd4babec9a7195e0317d46823dbff5d974b6133 SHA512 12a2827ccf0c6f920d265c583ff8dd91b6bed4a17492d927b37d446ea4cf852f4c842cbe1ae5faafc9a437cbe1725f68be1527c3182e5e2a29a6ad0315be3465
+EBUILD python-swiftclient-3.13.1.ebuild 926 BLAKE2B 5f4a4327b81c951545fb6bec0a6122d5ad4087c1f156a906c6f30c413afb2abd07a21019e8190f2f5b7612913a24b539839e732931f37c1e389023bbfb96e108 SHA512 0b312e8ee23b917cfcb2f03c4771f08bd30fc9d93cd38810a2f51af2122f5501946b716ba610a65592815db1b62408b61e8876cf6f4072ccd3bd0451c5828a4e
MISC metadata.xml 516 BLAKE2B fc43b031ba021a2a1cc6dbcb86764ef6f9cab62794220d4f3850050550a18a80dc112d0dd6d1be8562f1d6fd6d961057992e22abb4b4774c79bc69ac7c5402c2 SHA512 8858489aa10114c604eecd42e954d560a04d02e22c139f418b5d085c1be3fddac5d3e3c2ced39c2e4684d970569284ac988cb24d492e8997c3caad7e9ce59f05
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild
new file mode 100644
index 000000000000..c6468b9e5dcc
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ distutils-r1_python_prepare_all
+}