summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/python-swiftclient
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index 091be07f4df8..c6d81248cbbd 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,5 @@
DIST python-swiftclient-3.10.1.tar.gz 199466 BLAKE2B 4230f0fbff0e61a8172344df1cfc32f07628ac0b3784f5b8456d1b43b962e1d8561eec55c530ea94c615d46cd9454963fe0e21c54d1f4097016459e1460795c9 SHA512 f47444243f1968fdbba0643bcb4f05fc10a201b38ad83522e842bbad2221d0893a72147f9fbdc13e7f56469b049bbf11479fd9f41a9706119287543e0587f696
+DIST python-swiftclient-3.12.0.tar.gz 201199 BLAKE2B 36a5bc0ed7855b8ec8df51635ed6a2afba405c73809f3ab17c77e07dc362a2578816e63adf6c8da3b81ba8bfa8973326004c09bf980961b3c90987ecfdf95e30 SHA512 00e2b1b4d950396fba9232c251dbdf6949ea60e1f9de8f633ffcdeaa51339c5487fbccf9d9f337ef7aecba30e504338c592f9ed64d1d5c6798307a35b806f684
EBUILD python-swiftclient-3.10.1.ebuild 1477 BLAKE2B 2487fb1cdce42044c8840e65f93fdd083cd9b51a14ff69735476835a1b910e70b7bdb3dba83bdce2c5018d8fefddf84325b30467849347ebf6e2c473285d4132 SHA512 333f25cc332dbee41e391d75563da463dbcd33316546ab51693db8ffd7aff72ee28caf6b9738525a64f6b68533e0ab3dd6738ceaac4d070ed6849fc426c446f8
+EBUILD python-swiftclient-3.12.0.ebuild 916 BLAKE2B 2167280c078b707213f98dc0dba4aafad35133988c6392b2cf6e60373477368dc9979b5c5aa15c36fca2db8de621cdf44a027a71ded236ef8cbd1c44928388a5 SHA512 9ca46627152c4f25df45b3cc6dd112fdc4fa37b74fb42187d0928ef363a0053403c5993bdf8190985ad6a95d29dd31afe7437260149acc3ff6af3651c9974ddb
MISC metadata.xml 516 BLAKE2B fc43b031ba021a2a1cc6dbcb86764ef6f9cab62794220d4f3850050550a18a80dc112d0dd6d1be8562f1d6fd6d961057992e22abb4b4774c79bc69ac7c5402c2 SHA512 8858489aa10114c604eecd42e954d560a04d02e22c139f418b5d085c1be3fddac5d3e3c2ced39c2e4684d970569284ac988cb24d492e8997c3caad7e9ce59f05
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild
new file mode 100644
index 000000000000..061cfa612171
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-3.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ distutils-r1_python_prepare_all
+}