summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
commit15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (patch)
tree6da8c6fe191bb632a2a6454968d2d1cc1338a5dc /dev-python/python-swiftclient
parentec82846d15c127f36a0f0620e30c9c0fbbdd514c (diff)
gentoo auto-resync : 02:09:2023 - 10:15:56
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.4.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index da788c07f610..c891d988ea0f 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,5 @@
DIST python-swiftclient-4.3.0.tar.gz 206510 BLAKE2B 6a3683ffbe09905d310dabac5d1d3926125d85b8383e487d916df00e91621bc1bc901ed2ceed23a9ef4ecaf81e86f2560f77f20751a2b8c3ca543114ea5fa3d8 SHA512 8c113122b1dec2eb901b7256b0b5c9e6e3e11959ebdda28f512dd84b0370dcf8e7299594f50649c147526b4076baabf2a0fe6f6f433193d4c198890265f57807
+DIST python-swiftclient-4.4.0.tar.gz 206470 BLAKE2B d822af670fcb06a5977d070fb9e5ec1110f7ae275203d18eaeb0cd4335fe0e07f3f7e6b28e367834d33770d3a8b27a9af0c85cd30a1e9a7047ad908ca34f13bf SHA512 d3e814d367ff0c9a251524a50ce00cd89955edf43a542257142aa831d0d2d1f8dceb5b1b0b6456ad940c9aef78ec44bd1617fc45e47f64f045ddb591b5adb83b
EBUILD python-swiftclient-4.3.0.ebuild 1138 BLAKE2B 4332fd63e876d80e2d2a2497c5ef74de2687d8e07c28b044f892a130b375c891c8d9c69f5ce9fc33c05e60a71a1aad5d75e0f713994b1088b1938dabddc92435 SHA512 4dad500e323c271d818b5288b132c739696fbff83a590a85ff546750887f8bb1842cf713246ba85ae369d0d12a3130befc3113c402060e4019ec5261d24dddfa
+EBUILD python-swiftclient-4.4.0.ebuild 1141 BLAKE2B b932985cab6735bbad5e84ea57d2f2d62f3076b06dd15801494a9a8bd88568ef196eeda8dfd264fab0b174c2816c3e0967f0357523a6d6da4b630f1f980dacd6 SHA512 263de51f06098bb670b4c5ae965bf7ea13d265e64b01af492d9765c8e588f9218b13a81808c80ed45fe40e86ff0451623bb0c5396be146375cdd92964d2aecd7
MISC metadata.xml 668 BLAKE2B 299614e07d6b3f2d4acbc301cfddff8c1699acf3dac104de483e9dafdbf4cb34c8b933fdf7d91de3c26e73f34165338f68b46a44f3a113eb68b9b0270b9819c2 SHA512 f8b012262d487c873552beffe7107c8799bff52b6c61da575a9b2fa82d899d4e30d3a57f0885a119d8aebe87d5be61ea846d0766a409396acaa5fdb2b632e248
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.4.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.4.0.ebuild
new file mode 100644
index 000000000000..da32886df0b6
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-swiftclient/
+ https://github.com/openstack/python-swiftclient/
+ https://pypi.org/project/python-swiftclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth1-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ # fix duplicate script/entry point
+ # https://bugs.launchpad.net/python-swiftclient/+bug/1975361
+ sed -i -e '/bin\/swift/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}