summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/python-swiftclient
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest6
-rw-r--r--dev-python/python-swiftclient/metadata.xml4
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.0.0.ebuild (renamed from dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild)7
3 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index b275196210c5..8c5f400a8f34 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,3 @@
-DIST python-swiftclient-3.13.1.tar.gz 201632 BLAKE2B f7cdf7e30ea333f568c8ef06d065b18908b1e4c9f8f0b777906bdfa8f6c998292136859f62f0d2e58465ee9eec3452d29e3e69ed7567a07bfcddcf6ad1bf321c SHA512 bd958fb8cfde6f72bcf82d381ce06e0e94c383aee85abab5a111c408bacf2578eaf53244ae12438d4454fcefe8d867246aef952d1d15012364e20817cc90042d
-EBUILD python-swiftclient-3.13.1.ebuild 924 BLAKE2B 34f8cd9501e62c88efaeb8375456f5dba26d6a867c674f68a201e1f3302fdcaf4858ff45ce99260741f86f7d4e02efb7d14fad8adcb01871cedd130096cc45e6 SHA512 f78fdb10af2083b561f1c276e5dab1ca0deaa1a5acd1357525121d90360e05273b7245e161ab6ef46b5857719d568e1f7307e834cc08e46f7fb3cb69ba5e7e86
-MISC metadata.xml 516 BLAKE2B fc43b031ba021a2a1cc6dbcb86764ef6f9cab62794220d4f3850050550a18a80dc112d0dd6d1be8562f1d6fd6d961057992e22abb4b4774c79bc69ac7c5402c2 SHA512 8858489aa10114c604eecd42e954d560a04d02e22c139f418b5d085c1be3fddac5d3e3c2ced39c2e4684d970569284ac988cb24d492e8997c3caad7e9ce59f05
+DIST python-swiftclient-4.0.0.tar.gz 200490 BLAKE2B 37cadf27758640a916014e09309282a4b7ffebb3e578ae7411744fafd22431cfb748cffb4127309b20a8b2d8daca7f8f0a1ed6431f55766c33b243744ce5a71e SHA512 9058558564973ea2a4944e87dedd7b9b12e106672576da1d796eae336d3127ce8b35803cade93c605b38fd16a2d3466e6dc710838ceb77143059007625299360
+EBUILD python-swiftclient-4.0.0.ebuild 1056 BLAKE2B f238ad88b6d5af2b50a97ea8d9609223e051f9540e5d83ff1a59ef006609d4d9243e5ffcc7169ef8315cff903e36bf321fbaa0f8d1d81297eb9be4a591525dad SHA512 70a794f5441ba89d9fe557d532b7de99b0abddb415683023f0b8587cb187385ad6cc13773d5c87e9433b0e288f2248b5a6b9575e1c8df46da6878a6b4c0c9859
+MISC metadata.xml 623 BLAKE2B 168e5384739e27a69e799a4e94038a8b7ba8434a439f92f601657ab4404c2f610da2324364a73c982aadc39a691fc368099b0ed604209331e9d83a33da1ece67 SHA512 d3028eb4ff16c9baae166c749c40388d45627a583ce041ece508f66cd8eea2f5f1ab72eed930c860497d6cb1e3e7f03c20f165c661197c4e507bf5a2c6833d1d
diff --git a/dev-python/python-swiftclient/metadata.xml b/dev-python/python-swiftclient/metadata.xml
index 37cbe1d28ab3..1ea027c4474c 100644
--- a/dev-python/python-swiftclient/metadata.xml
+++ b/dev-python/python-swiftclient/metadata.xml
@@ -8,6 +8,10 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">python-swiftclient</remote-id>
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.0.0.ebuild
index 3bbc276c77e9..4ec90b98b6ca 100644
--- a/dev-python/python-swiftclient/python-swiftclient-3.13.1.ebuild
+++ b/dev-python/python-swiftclient/python-swiftclient-4.0.0.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,8 +17,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
RDEPEND="
- >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
"
BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
@@ -33,5 +33,8 @@ distutils_enable_tests unittest
python_prepare_all() {
sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ # fix duplicate script/entry point
+ # https://bugs.launchpad.net/python-swiftclient/+bug/1975361
+ sed -i -e '/bin\/swift/d' setup.cfg || die
distutils-r1_python_prepare_all
}