summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 21:42:17 +0100
commit90a3be9d71a22834f9bc82c072f1b993f9a10e31 (patch)
tree7f86c1f37e857df29494ec91436ca76bed49441a /dev-python/python-stdnum
parenta597364520b9291d0b2a23bb007ced022e821d95 (diff)
gentoo auto-resync : 20:08:2023 - 21:42:17
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest2
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.19.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 2c0144fc70f2..eab9fe8b2940 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1,3 +1,5 @@
DIST python-stdnum-1.18.tar.gz 1138676 BLAKE2B 724afd5d015090023582bc078f278d4107a12d4f126a61eb026b69040654d0890dc0eb0aa197565e844c34f0426f7f0072dac2b8191ba3a15bc87ae7c0b73536 SHA512 ca211fa3f7a0c0a913c5b0c6e32cb477025e203eb4c0a648e47bf95cb361d800d620dc4ebcb3007eefbb5595098486963ffee71ea2c37f84d86443d01131db7c
+DIST python-stdnum-1.19.tar.gz 1134517 BLAKE2B a6e35abcd00302dff0c6df82c13691c4528de069b7702f905aabffd840b7d95902f2c74525d824606bc4b28579d38153367997a73910ab93afb4eb4272b76c40 SHA512 02c56aea710a9a02e14160840fbd45751cd00f1a49b1d046124945ba92e2dd3377006f44a146030522d09b92f809ceb4d1e3589ef3d9c9302f7674a79602ef07
EBUILD python-stdnum-1.18.ebuild 733 BLAKE2B ea90d3f6eff04e0b129458b4563140263de4679e4844cd582e01d7f5033de166b8de84a8576d2f9245d10cef8082768e705e625b607febc012b533795f96d776 SHA512 8e5cc8a326ff4bd1a3f23489fba833dae9abeceaf382d5202223ddf6dfdc6ee427fd84a09b49e728c845bd2f43c93ba1e2abf4e2ef487b87b231789b0f89dab3
+EBUILD python-stdnum-1.19.ebuild 736 BLAKE2B 4db963c5eff6ad2530bb82875e9cb50c7146e382b2dbf527ef6b8e394c934e505c999aa96b5efadbc32987d7ac1b684a1b6dccd7fc119045d8fae0833171efa4 SHA512 1e95500dc3218a27dfabfb1b27733349172d515a10cb72c3c6e1e7b614ab825fa129a077b32c6e238f799346949b8736fbacafc1963f5ec4c2ed559b994800b0
MISC metadata.xml 461 BLAKE2B ca459eeb4a49d155ee0e1f53a3830f500607e7b412c9546c05e54c99fb2d74982e4bb3815fb5373b627d09c580f3f6807737b33022542f0fb13ed45c085e57e1 SHA512 66ebd3c6792e7bc35df1b77171179191a98c476c38827fb11cfff1e0c003317a2eb296ae12cea484bdcfbfd364dfafb0abc60cf0886c993b66860f7d9efe6013
diff --git a/dev-python/python-stdnum/python-stdnum-1.19.ebuild b/dev-python/python-stdnum/python-stdnum-1.19.ebuild
new file mode 100644
index 000000000000..2bdc447fc8ce
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.19.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="
+ https://arthurdejong.org/python-stdnum/
+ https://github.com/arthurdejong/python-stdnum/
+ https://pypi.org/project/python-stdnum/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds-community[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov.*::' setup.cfg || die
+ distutils-r1_src_prepare
+}