summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum/python-stdnum-1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /dev-python/python-stdnum/python-stdnum-1.12.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.12.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.12.ebuild b/dev-python/python-stdnum/python-stdnum-1.12.ebuild
new file mode 100644
index 000000000000..afa8a22186a7
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="vies? ( || ( dev-python/zeep dev-python/suds ) )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests -v || die
+}