summaryrefslogtreecommitdiff
path: root/dev-python/python-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-29 22:43:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-29 22:43:19 +0000
commitfa19575643c607e28b1572821c413ad7cb8eea09 (patch)
tree9d9b05acd34c77d7708182eac258ad26975949c7 /dev-python/python-socks
parentfc4ad6e568738af8995c2e87896c671c39eb8c72 (diff)
gentoo auto-resync : 29:01:2025 - 22:43:19
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest2
-rw-r--r--dev-python/python-socks/python-socks-2.7.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index f0a06c0017af..ab5197f43f32 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,5 @@
DIST python-socks-2.6.1.gh.tar.gz 32352 BLAKE2B 0bfc85bdeb6aefab34d307a6956171fad8b0876f49959bfc91193c864ba8ed7d05a1efb4f052202d99984aad7bb9bfc8472e2853d57b5812156dec6ee791a04e SHA512 2e046849a66125ddb14f887f84354e56f689034695a48532cbd4d4a1ef9508212c30e34faeb3b318ceede32a0604d62f92ca92cfe14b63c54a42fd5c1cfafbc0
+DIST python-socks-2.7.0.gh.tar.gz 32361 BLAKE2B 603e9782ee2998825bbcff012e1eeba7e404f13112544c6db97e5baf31ac79cb9339d98642c20a56fc5a1ef7da4a60687e663770ec0c145015648c07f99c341d SHA512 0244a6111ba37341e06210422af1df5946edd0e87616647aa2bbaf0cb82c363db3489eeddbd2111cbb76a126b5d629a2426776316b7ea68a17d3aa4fea2901f1
EBUILD python-socks-2.6.1.ebuild 1327 BLAKE2B 2863b27a06a561c7a67c489a3412ec53d7ac0f288633fbe457c993a792ade2d05c0a1b2e78c8bec44ffbccc4491d6519c825ea5a0e2179d0d871655c4f9ccd89 SHA512 c824b3f5ad21ba8a0500cc96565da85b872663caf43af7599e9a39c3ced5001a1837846b461073358c39e19a6274b3164b2abb91221ec7d3c04e63050618c5b9
+EBUILD python-socks-2.7.0.ebuild 1335 BLAKE2B cf8a94496ea5089591bb25f7f0164d5b6699314409a321f5459a65a06fa0c3d8c02fed8944735ff632f13a853f8fadecab7c4f33195a1c57e579b362e740aca0 SHA512 451fcd62ec94f1878c6523a11c053aa84432190852ce18c8b9f9c8d24aa71f6e9ddadd55c722c8c01e242023fe415774127aee91099be05c410cda835bf97379
MISC metadata.xml 380 BLAKE2B 2209abdbafd26baae585840e774843c37e0c6103fa93d75e8c1ddbc8dd1b96f269a3e76f14c39a55294d4d642d7fbe9f87c6b1a0b64152c671590a9e0a6ef959 SHA512 ccbb1a5c9fd05ae1da346f4f92efe156921f7adf9f5544635a407ba4a8154c896bda2e445e05e70a8e46c2829b8d4a38d3bf5d73804a3641c811acd2be62099a
diff --git a/dev-python/python-socks/python-socks-2.7.0.ebuild b/dev-python/python-socks/python-socks-2.7.0.ebuild
new file mode 100644
index 000000000000..841c4392d877
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.24[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest