summaryrefslogtreecommitdiff
path: root/dev-python/python-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-09 11:11:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-09 11:11:11 +0000
commit90a73bb153519a9eac2a23eb9029b99b759e7892 (patch)
tree6d01f49a1e594c9324241c03aac67a635f828834 /dev-python/python-socks
parentf6f5cf314dddfbfe0f8c848dc9e07436b032562c (diff)
gentoo auto-resync : 09:12:2023 - 11:11:11
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest2
-rw-r--r--dev-python/python-socks/python-socks-2.4.4.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 37850aeb4413..f6980379667c 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,5 @@
DIST python-socks-2.4.3.gh.tar.gz 32006 BLAKE2B 571c04e5b12ddff3e6d813b547b43899883ef132ad0e55c2fce33ae9e4cd63ca588fb700aba7e2ea5c021f55c7aeae0f8213d2aa8fca3d7bff502b7bd00ca854 SHA512 5ef55367b1fae2249690df0eb8ea55284f02287115b14e8b7ebeeed9ae3e8ed431e17247f369323651daa1177ac8c6dd207d5dd188134e04eff178dc240b9b8b
+DIST python-socks-2.4.4.gh.tar.gz 31998 BLAKE2B c3aa137ff679790420ded9644987eed23695c82a5621c420350ad52ca8121215326575f4c389912fb646151fc84187bfab38674ff6dc2a2f3587c4662f51c0f6 SHA512 a357fbd16cf653555bb624103732041efa80b1ae21a6347fdcb609de3cc58227ac053d21b62124fd77b21a16b19a2786bc1a8c33cc3b50dcffb3023bd6704f57
EBUILD python-socks-2.4.3.ebuild 1294 BLAKE2B 4855bc0e8d916510a8e4fed16e2a83faa9a7f937aee679bd1ffdcf726ae33ad8c9bf4064d7a92c34a047f3e358976d16d998f48ff2c47dcfb2fa2eefc06d0f55 SHA512 05b6643cf85bbeb433144330f3ecf2b21e785885ae0528f0744bddee7721f80e99325c654681a4dabdf436a1656fcde115ddb3c9f1680e0e012b9669ad6f475f
+EBUILD python-socks-2.4.4.ebuild 1302 BLAKE2B 402dc7ee78b0824413eaba01d994f6a1eaafd23ae8ef5b89a90d512e4f86624ee74c329d1c9a8b21cb304e8575e1b366988dc29ffd99d3472fcd990ab23b82f8 SHA512 82aaf2ebd43caf61deb8eae64c7c5b1ca566175bb3b9dd9c624f412363759cda97937d2b500a318cc175f3909a4e8434a2f1b898964e3a35cc2e1a3d31fdfa6d
MISC metadata.xml 380 BLAKE2B 2209abdbafd26baae585840e774843c37e0c6103fa93d75e8c1ddbc8dd1b96f269a3e76f14c39a55294d4d642d7fbe9f87c6b1a0b64152c671590a9e0a6ef959 SHA512 ccbb1a5c9fd05ae1da346f4f92efe156921f7adf9f5544635a407ba4a8154c896bda2e445e05e70a8e46c2829b8d4a38d3bf5d73804a3641c811acd2be62099a
diff --git a/dev-python/python-socks/python-socks-2.4.4.ebuild b/dev-python/python-socks/python-socks-2.4.4.ebuild
new file mode 100644
index 000000000000..de1dfe5d6c9b
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.4.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest