summaryrefslogtreecommitdiff
path: root/dev-python/python-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-08 16:31:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-08 16:31:05 +0100
commit5e2dc8e9ee14034d872c67b64a63af413f63ad47 (patch)
tree3d0a4bb80b0adf1d4076a3dfb8415dfa5d2aa424 /dev-python/python-socks
parent2c1bdf9e63a9a82efe90cc9d82696812db076f7f (diff)
gentoo auto-resync : 08:09:2023 - 16:31:05
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest2
-rw-r--r--dev-python/python-socks/python-socks-2.4.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index bd59d7282204..2608b5cbb725 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,5 @@
DIST python-socks-2.3.0.gh.tar.gz 32506 BLAKE2B 0eaddbb4400488b6c96458d84671e69c9dd9bf927b9ea830d4161d4d78bdc32f66fb0c02f19e63afa868bd248a95d1544463bc877b79fd533b3952bfc71bef52 SHA512 792489d9daa63847733580b36d85d143146d0cd0b3f29297fa732516dea203b3f82deaf2779b56d80c20abe2739ed79e28a9a21cfeb26768ec557efef34c74f7
+DIST python-socks-2.4.1.gh.tar.gz 32003 BLAKE2B 70f1df51583d55372bad61cf3acdc62d8b487f061a3d3c1a6bac86e7f8b2f00e81a041354406ac43e4b0dc9150e165ed09ac5794a74827e84ada08c060c844fd SHA512 be26dd0bf6eb886c00ee5a4a5108ad883252cdb40fe4daed20b3e06e8a667e57a1dd0f7aa9ff669b2b36c804e8c2b039fef10d69d90659615cdb7feb31292ceb
EBUILD python-socks-2.3.0.ebuild 1294 BLAKE2B 4855bc0e8d916510a8e4fed16e2a83faa9a7f937aee679bd1ffdcf726ae33ad8c9bf4064d7a92c34a047f3e358976d16d998f48ff2c47dcfb2fa2eefc06d0f55 SHA512 05b6643cf85bbeb433144330f3ecf2b21e785885ae0528f0744bddee7721f80e99325c654681a4dabdf436a1656fcde115ddb3c9f1680e0e012b9669ad6f475f
+EBUILD python-socks-2.4.1.ebuild 1302 BLAKE2B 402dc7ee78b0824413eaba01d994f6a1eaafd23ae8ef5b89a90d512e4f86624ee74c329d1c9a8b21cb304e8575e1b366988dc29ffd99d3472fcd990ab23b82f8 SHA512 82aaf2ebd43caf61deb8eae64c7c5b1ca566175bb3b9dd9c624f412363759cda97937d2b500a318cc175f3909a4e8434a2f1b898964e3a35cc2e1a3d31fdfa6d
MISC metadata.xml 380 BLAKE2B 2209abdbafd26baae585840e774843c37e0c6103fa93d75e8c1ddbc8dd1b96f269a3e76f14c39a55294d4d642d7fbe9f87c6b1a0b64152c671590a9e0a6ef959 SHA512 ccbb1a5c9fd05ae1da346f4f92efe156921f7adf9f5544635a407ba4a8154c896bda2e445e05e70a8e46c2829b8d4a38d3bf5d73804a3641c811acd2be62099a
diff --git a/dev-python/python-socks/python-socks-2.4.1.ebuild b/dev-python/python-socks/python-socks-2.4.1.ebuild
new file mode 100644
index 000000000000..de1dfe5d6c9b
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest